Problems with paperspace and jupyter notebook

I have set up a machine on paperspace using the fastai option and going through the setup instructions on github. The machine will not update the conda env update command. I get this error: CondaError: Cannot link a source that does not exist.

Also, I am trying to open up jupyter notebook from the remote terminal using “http://localhost:8888/?token=db4e774f2728b8413866e31ccf9fcf31b960b23a9ef60a23” but replacing localhost with the IP address they provided when the machine was made (as mentioned in the setup instructions) and getting error: “This site can’t be reached”.

Any help is appreciated. I didn’t ssh into the remote but thought that was optional.

@keri, if you are ok with using ssh to connect with the paperspace machine they do it. I use paperspace everyday without issues. Also, instead of using the fastai image in paperspace, use the method jeremy shows in the video, to install the fast ai library on a blank machine.

Thanks for the fast response. I also realized that I have an Nvidia GPU on my local machine so will attempt to set up the environment locally and try your suggestion if that doesn’t work.

have the same problem, any updates to the issue?

Same problem here

I ended up using an AWS instance and that has worked well.

EDIT: Figured out my issue. Was trying to connect from a public library. Something about their WiFi configuration doesn’t allow what I’m guessing is an insecure connection to the public jupyter notebook server (though ssh’ing into Paperspace works fine, I’m guessing since it’s secure). Switched WiFi networks and now everything is working fine.

I’m having the same problem.

Weirdly, it worked for me the first time, but since shutting down and then starting back up my Paperspace server, I can no longer connect to the jupyter notebook. I can set up the jupyter notebook endpoint with no problems, but can’t connect to it from my local machine.

I’ve tried stopping the jupyter notebook server and rerunning a number of times (resulting in different tokens). This hasn’t changed anything.

I was also getting “This site can’t be reached”. Running jupyter notebook --ip=* worked for me. Now I can access my jupyter notebook with my cloud machine’s public ip.

1 Like

Thanks John. The above command worked for me as well.

I tried the above fixes but couldn’t get the page to load. Ended up finding this command

jupyter-notebook --no-browser --ip= --port=8888

not sure why it wouldn’t work when i had set the ip in the config file though.


This helped me with the issue, thank you! I was able to ssh into my server, but couldnt open the notebooks from my local computer, when just using jupter notebook from the server. By changing that to:

jupyter-notebook --no-browser --ip= --port=8888

I was able to use the notebooks in my local browser without a problem :slight_smile: