Problem with wget of

Hi I am at the very beginning trying to get set up. I tried cygwin but it could not find python. Based on the forums using this shell was suggested by Jeremy:

Unfortunately I am on windows 7 due to a compatibility issue on another project so I instead of trying this shell which is for windows 10 i am using git bash on windows 7. I installed wget from

when i run wget on i get the following error:

$ wget
–2017-11-10 10:28:37--
Resolving (…
Connecting to (||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 2520 (2.5K) [application/x-sh] Permission denied

Cannot write to ‘’ (Bad file descriptor).

I am new to most of this so may be missing something obvious but have not found a solution via Google. any help or suggestions greatly appreciated, thanks

I managed to setup everything manually in win7 environment without cygwin or script files.
Maybe you want to try that also.

Thanks, that was easy. I just downloaded to my windows machine and put it in a folder where i could access it.

When I run bash on Linux Terminal after “aws configure”

I am getting the error as,

An error occurred (OptInRequired) when calling the CreateVpc operation: You are not subscribed to this service. Please go to to subscribe.
usage: aws [options] [ …] [parameters]
To see help text, you can run:

aws help
aws help
aws help
aws: error: argument --vpc-id: expected one argument
[1]+ Stopped bash

P.S I am using region as “ap-southeast-1”

refer common issue related to AWS