Problem with locally previewing blog

Hi, I am trying to run my fastpages blog locally. To this end I am following the instructions outlined in the Development Guide. I have Docker installed. According to the Development Guide, I should be able to see all available commands by running make in the root of my repository. However I get the following error:

PS C:\Users\kfdah\Desktop\projects\personal-blog> make
make : The term 'make' is not recognized as the name of a cmdlet, function, script file, or operable 
program. Check the spelling of the name, or if a path was included, verify that the path is correct and 
try again.
At line:1 char:1
+ make
+ ~~~~
    + CategoryInfo          : ObjectNotFound: (make:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

I don’t have experience with makefiles (only learned about them by trying to follow the Development Guide.) Is there some step I am skipping? Any help would be appreciated.

It doesn’t work on Windows – try using WSL instead.


Using WSL did the trick indeed.

In case other people run into this, there were some additional steps I had to take (probably trivial to people who have experience in using Linux and Docker):

  • In the linux terminal I tried the command make server, however I was getting a ‘Permission Denied’ error. Use sudo make server instead.
  • The development guide mentions here that a Jekyll server is set up which can be used to preview the blog. The url mentioned is However I was getting some error mentioning https. After changing https into http it worked.

Also, for VSCode integration:

Hope this is helpful.

Great glad you got it working.

FYI you can do this without Docker. Just run WSL and it should all work fine.

Thanks. Yes, the Docker part was for VSCode integration. I will clarify it in my previous post.

You don’t need docker for vscode integration either. vscode has a WSL connector you can use directly.

I tried to run the live preview, this time without the WSL integration option for Ubuntu enabled in Docker Desktop. VSCode starts complaining about Docker however:

Also Development Guide states you need Docker. So I don’t understand why you state that Docker is not needed for VSCode integration.

The guide says “if you use vscode with docker”. It doesn’t say you need it. Here’s how to use vscode with wsl: