Problem while updating the fastai library in conda

I use the fastai library in anaconda on my windows laptop and installed it using
> conda install -c fastai fastai
At the time of installation the current version was 1.0.38 and now it is 1.0.42. I tried to update it using
> conda update -c fastai fastai
but it shows packages already installed. Also tried with specifying the version (fastai=1.0.42) but it shows packages not found.


Can you try a conda update all?

Also, I’m note sure if its easy to use your GPU on windows. Did you try dual-booting/were you able to setup your gpu env on windows?

conda update all doesn’t work. Using fast ai on windows is pretty straightforward with anaconda, but this update issue is bugging me because some new functions were added in the library and I cant use them because it wont update.

Try this:

conda update conda -y --all
pip install fastai --upgrade

Hope it will fix it for you. (If you are using envs make sure you activate the appropriate one & then issue the update commands)

1 Like

It worked. Thank you!:smiley:

I also used the 2 lines to update the fastai library. I got no errors. I launched Jupyter Notebook and saw my directories. I even renamed a notebook file within Jupyter. But when I tried to open any notebook file I got:

500 : Internal Server Error

Any thoughts on how to trouble-shoot this?

Thank you, Dana

I solved my Jupyter “500 : Internal Server Error”. In this case, the solution was one more update:

conda upgrade nbconvert

That may not help the next person because Jupyter “Internal Server Error” can have many causes. The way I found the answer was to look at the output of my terminal process that was hosting “Jupyter”, and read the call stack to find an error. The error there was more precise (your error would be different):

“module ‘tornado.web’ has no attribute ‘asynchronous’”

Then I googled that error along with “Jupyter” and found someone with the solution.

1 Like

I am new to this course and just completed lesson 1.I am using to set up but facing the same issue. I already tried the above two commands but still not able to resolve it.

For all you have to do is to follow the setup/configuration instructions provided by fastai. This is the easiest and direct approach. You don’t need to run anything else.

conda update conda
conda install -c fastai fastai
1 Like

@mansi I was able to solve it by just upgrading fastai from pip:

pip install fastai --upgrade

I followed the normal instructions for getting up and running with crestle including the following

conda update conda
conda install -c fastai fastai

but I still had to resort to the pip upgrade to get the right version of fastai installed.

1 Like