Problem Installing Fastai - errors out installing pyproj


I’m setting up a new environment and getting the following error when installing fastai. I’ve installed fastai with no problems in the past…any suggestions greatly appreciated.

Thank you.

Collecting pyproj (from geopandas>=0.3.0->plotnine->-r /home/cbigadmin/fastai/condaenv.picgbjpu.requirements.txt (line 9))
Using cached
Complete output from command python egg_info:
using bundled proj4…
Traceback (most recent call last):
File “/home/cbigadmin/anaconda3/envs/fastai/lib/python3.6/distutils/”, line 118, in _compile
File “/home/cbigadmin/anaconda3/envs/fastai/lib/python3.6/distutils/”, line 909, in spawn
spawn(cmd, dry_run=self.dry_run)
File “/home/cbigadmin/anaconda3/envs/fastai/lib/python3.6/distutils/”, line 36, in spawn
_spawn_posix(cmd, search_path, dry_run=dry_run)
File “/home/cbigadmin/anaconda3/envs/fastai/lib/python3.6/distutils/”, line 159, in _spawn_posix
% (cmd, exit_status))
distutils.errors.DistutilsExecError: command ‘gcc’ failed with exit status 1

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/tmp/pip-install-rfh3ynux/pyproj/", line 72, in <module>
    objects = cc.compile(['nad2bin.c', 'src/pj_malloc.c'])
  File "/home/cbigadmin/anaconda3/envs/fastai/lib/python3.6/distutils/", line 574, in compile
    self._compile(obj, src, ext, cc_args, extra_postargs, pp_opts)
  File "/home/cbigadmin/anaconda3/envs/fastai/lib/python3.6/distutils/", line 120, in _compile
    raise CompileError(msg)
distutils.errors.CompileError: command 'gcc' failed with exit status 1


Command “python egg_info” failed with error code 1 in /tmp/pip-install-rfh3ynux/pyproj/

CondaValueError: pip returned an error

Hi @ecocarlisle ! Have you been able to solve this issue. I need some help.

@anand9499 not yet. I moved on to using a Windows machine. One suggestion would be to see which version of pyproj will work and to update the fastai config file and then try again. That is, try the earlier version by explicitly entering the earlier version in the fastai config. Hope that makes sense. That same concept worked for me when I ran into a similar issue with Windows.

@ecocarlisle have you tried with the latest README instructions ? (updated 12h ago)

(This weekend I wasn’t able to install fastai but now it works)

Don’t use those instructions for the course - that’s for v1, but the course uses 0.7. I’ll update the readme to mention that.

For the course you should do conda env update instead.