Platform: Salamander ✅

Got it :slight_smile:

I changed to jupyter notebook from jupyter lab and it works, also much faster execution. It seemed to hang on some steps after I restarted Jupyter Lab.

I don’t know if this is a Salamander issue or not but can’t find any previous posts anywhere.

I’m not able to run:
pat = r’/([^/]+)\d+.jpg$‘i
I get:
File “”, line 2
pat = r’/([^/]+)
SyntaxError: invalid syntax

The carat is under the i. I’m rusty on RegEx and hope I don’t have to learn Python RegEx right now!

@ricknta Try, not really a suitable issue for this thread though. Definitely unrelated to Salamander… maybe fastai related? If you didn’t write the code yourself maybe create a new thread with some additional details or create a PR on github if you figure out a fix yourself

@dwcar49us interesting, another user also reported slow execution with jupyter lab (last week)

@ashtonsix On a hunch I deleted the “i” and it runs fine… maybe that i just sneaked in there somehow… :slight_smile:

1 Like

@ashtonsix is there anyway to change the payment information or delete your account? The payment field disappears once you save 1 credit card. There’s also no option anywhere to delete the account.

Also, are you single-handedly running these servers?

@bjinwoopark I can remove your card details if you email me (

The servers are turned on & off by code I wrote, not me personally.

@ramon would you mind removing the error from your post as a courtesy to others scrolling down?

It’s more likely related to Jupyter than Salamander. If you encounter this issue again try restarting your kernel, or if you have other notebooks open try going to the “Kernels” tab & shut all the other kernels down to free up your memory (& restart the notebook you’re working on). Stopping & starting your server again is the nuclear option - you shouldn’t need to do that.

I’ve edited it to use a details section like so:

[details=error message]

@ashtonsix I was really pleased to get an email from you yesterday saying my server was idling. Great feature! You should advertise that.


@ashtonsix Also a question: Jeremy mentioned on Mon. that you would be accepting the AWS credit in a couple of days. Is that possible yet?

Hey, as you can see even fastai-0.7 in Jupyter notebooks it is not able to import fastai. I have simply copied the imports of the old fastai lesson. fastai v1 is working fine. Can you pls fix this?

I have found a temp fix. I installed fastai-0.7 following Howto: installation on Windows . It seems to be working fine but the kernel is python.

When I try to train the model with this installation I get “RuntimeError: cuda runtime error (59) : device-side assert triggered at /pytorch/torch/lib/THC/generic/THCTensorCopy.c:20”

@bluesky314 please use this forum category for fastai v1 and course v3. To discuss previous versions, please use the appropriate category (e.g. #part1-v2 ).

1 Like

@ricknta I’m adding the aws credit stuff later today: it was harder to build than expected (not possible through API, you have to programmatically control a web browser).

@bluesky314 will investigate (worked for others), let’s continue conv elsewhere.

1 Like

everyone, but @ricknta in particular:

You can now redeem AWS credits on Salamander:

This feature isn’t 100% stable, but I’ve run out of my own coupons to test it with & keep building. There’s no AWS API for coupons, Salamander is controlling a web browser for this.


For folks that try this, please let us know here if it worked or not. Once we’ve got enough reports of success, we can update the wiki post to let folks know it’s stable.


a quick clarification requested

Is the $50 google credit & $250 AWS credit available for ‘remote’ students also? Or is it only for in-person students?

Thanks a lot

@sujithvn I think the $250 AWS credit is just for usf students. However, if you’re a student anywhere else there’s $110 credits available via a partnership with github. With AWS on-demand that’s 122 K80 hours; 223 hours on Salamander.