Platform: Paperspace (Free; Paid options)

Official Paperspace reps: @dkobran @tomg

Basic steps

  1. Select Gradient then Notebook
  2. Recommended Containers will display by default.
  3. Then the Paperspace + Fast.Ai 2.0 (V4) container
  4. Select a machine (note that the free GPU machines are subject to GPU availability)
  5. Select a name for your notebook
  6. Then click on the button “Create Notebook+”
  7. Wait for your machine to be ready then click open and you should see a jupyter notebook home screen with course-v4 already there!

FAQ

  • Everything that is saved in the “storage” folder is persistent across all your notebooks.
  • Advanced users only: To use the master branch of fastai, execute the following cell at the top of a notebook:
!pip install git+https://github.com/fastai/fastai2 
!pip install git+https://github.com/fastai/fastcore
9 Likes

I did not have any problems setting up the container or notebook, but when I ran the first cell of code, which was:

from utils import *

I got the error No module named 'nbdev'. Is that expected?

For now running a first cell with

! pip install nbdev graphviz azure-cognitiveservices-search-imagesearch

should fix that issue. I’ve asked the Paperspace team to add those to the image.

Edit: I have been told they have been added, so it should now work on a new notebook using this image without having to do anything.

7 Likes

I’m trying to understand what is expected to be loaded in the nbd folder per the intro lesson. There’s no images folder (I can make it, but I assume that’s not expected), and running the 5th cell returns “AttributeError: module ‘ipywidgets.widgets’ has no attribute ‘FileUpload’”. Can you advise? First time running jupyter on paperspace so some serious gaps in my experience.

Edit - I also made sure to run “!pip install ipywidgets” in a cell beforehand and that doesn’t influence the output

I got the same behavior than @bostonsparky

@bostonsparky @cuby It looks like a change was made adding the images directory after we cloned the repo this morning: https://github.com/fastai/course-v4/tree/master/nbs

Sorry about that, we’re updating the container now. Nice find btw!

1 Like

I’m running the free tier and every time I run the first training command I’ve been getting

OSError: [Errno 12] Cannot allocate memory

anyone fix this?

edit*

We’ve published a fresh container. Please give it a shot! :]

4 Likes

Did you follow the upgrade and git pull steps?
Are you talking about the first training command in 01_intro.ipynb under Running your first notebook?
Which Machine are you using?

Using the new container worked, thanks!

1 Like

I was using the free container, I tried using a new one but it didn’t help. The new published container worked.

1 Like

What’s the minimum GPU needed? I don’t mind paying but I don’t want to pay more than I need to.

1 Like

@csw It’s free! You should see a a few different free instance options when creating a notebook. The one labeled Free-P5000 is the most powerful instance :slight_smile:

Screenshot highlighting the free instances and the P5000:

8 Likes

Yes, it works now. Thank you!

2 Likes

Hi. I tried gradient for the first time today and I could run jupyter notebook in less than 2 minutes. Thanks a lot for making it so easy Paperspace team. I have couple of questions.

  1. When I stop notebook instance, does the changes that are made to jupyter notebook gets saved when I open the notebook again ?
  2. Is it possible to change the instance type dynamically while running a notebook?
  3. Can I download all the required repos from fast.ai to storage since the folder remains persistent across all instances and then do pip install -e . for fastai2, fastcore etc?

Thanks
Ravi

1 Like

I can confirm that it works now with out pip installing the above pacakges

2 Likes

@deeplearner Great questions:

  1. Yes, no need to do anything but stop the notebook
  2. Changing the instance type requires a stop/start – we are investigating supporting this in realtime.
  3. Yes, absolutely. There is no need in this case since all the fast.ai contents are preloaded but you can use /storage to store anything.

Hope that helps!

4 Likes

Awesome. Thanks for the reply. I will use the /storage to store some of the packages :slight_smile:

2 Likes

In the actions, I see one that says open v2(beta) and open v1 classic. what’s the difference?

2 Likes

@Grace1 We launched a new interface that among other things, allows you to view the notebook when it is not running. We recommend the new interface but either option is fine :slight_smile:

3 Likes