Platform: Paperspace and Gradient ✅

The one I showed earlier:

It can’t seem to find container nm7ij0zc

It was able to start the older one, nu0y82o1

This is still broken!

1 Like

Having same error.

I had to get Paperspace tech support to fix it for me

For Gradient I always need to start a new notebook each time from scratch because opening doesn’t work (as per other issues). Since the /storage is preserved this isn’t a big issue.

For lesson3-imdb I get an ascii decode error like this:

A workaround is to manually set the codec in the notebook:

import locale
locale.setlocale(locale.LC_ALL, 'C.UTF-8')

Before I saw your post I saw this:

and that worked for me.

It’s great to know that works in Gradient too. Where are you running this command? In a Jupyter terminal?

Yes, ran that in a terminal. But later when I returned to the IMDB nb I had a similar ascii codec error and used your method in the nb to fix it. Strange that it’s not a persistent setting… I do find it quicker to just run it in the nb.

Two things - I realized that one of my issues with fastai was using pytorch 0.4.1. The issue was that I HAD pytorch verion 1 installed (pytorch nightly) but did NOT uninstall pytorch 0.4.1. Simple but inintuitive to a beginner.

My second is the same issue as @ricknta was having where I cannot download the Amazon dataset - however when I click accept on the Kaggle page it simply does nothing! I’ve tried accepting on firefox and on chrome. Any ideas?

@agoldina : Did you upload the kaggle.json file into the ~/.kaggle directory?

Or maybe try recreating the API token and redo those steps.

Sasha, it’s been almost 2 weeks so I don’t recall exactly what happened, but I think I had just failed to find the Accept button way at the bottom of the Kaggle page. I think when I clicked it, nothing happened, but then when I ran the code in the planets nb it downloaded properly. Hope this helps.

I’ve clicked accept and the code still fails to run :confused:
I’ve downloaded data from kaggle successfully before too

Is anybody finding that the directory /notebooks/course-v3/nbs/dl1/ is empty? I have (or had) my own notebooks, in addition to those from the course here, but today I find this directory to be empty. If I do git pull, it is still empty. I found this issue a couple of weeks ago, but after some hours the ipynbs re-appeared. Thanks.


@dillon @dkobran

Notebooks are missing!!! I just ran a git pull. Root folder looks like this after re-starting:


but looked like this before:

and the nbs folder is missing completely!

Please fix this ASAP!!!

I had the exact same issue more than once. Sometimes the whole nbs directory is missing, sometimes only dl1. I contacted support but it did not help much. Finally I opted to create a new notebook and start over (I had my own ipynbs in a repository so it was easy to move them back to the new nbs/dl1/). Now I am having another issue which is that even though I save my ipynb, when I stop the notebook and re-start it later, the version of my ipynb is not the most current. I give up with paperspace, I’ll try another service.

I agree; I’m planning on moving to GCP soon. I had no response to my post from Paperspace. I’m using Gradient and went back to the previous nb so I don’t think I lost much work this time, but it’s really upsetting to have the platform this unreliable.

1 Like

@dillon @dkobran

No gpu’s available??!! Tried to restart a vm, had only a list of cpu’s, no gpu’s. Now tried again, has only GPU+, but I wanted to run with a faster gpu. What is going on???

this worked for me but I had ‘cd course-v3’ before git statsh, git pull as stated, at first i did git pull from home directory, thinking it would update everything, but it didn’t work until i cd’d to course-v3 directory.

@dillon any advice for installing the Anaconda Extensions for the Jupyter Notebook on a Paperspace instance (using the 1.0 / PyTorch 1.0 BETA container)? I followed the steps outlined here after finding this on the forum, and the install finishes successfully in the terminal, but it doesn’t seem to be working because I don’t have the nbextension option once I relaunch the notebook.