Platform: Paperspace and Gradient ✅

Paperspace site is down??? I get

Error 504 2018-11-08 04:30:05 UTC

Gateway time-out

Help!! @dkobran @dillon

Now the site is back - sort of - but but my notebooks are gone, payment method is gone, can’t log out…

Now it’s

Error 504 Ray ID: 476560322d159b9f • 2018-11-08 04:43:55 UTC

Gateway time-out


and now it’s back, with the banner:

Alert: Paperspace is getting updated! During this process there is a chance you will be disconnected for a minute while we upgrade your machine.

But it was about 15 minutes… would have been helpful to see the banner earlier! and it shows my machine has been running for 30 minutes!!

@ricknta : Did you go to Kaggle competition page and accept the rules?
Something like above.

1 Like

You’re right, that’s what I had been missing - I found there’s a topic for the Planet nb so posted this problem over there:

and got the same answer there. I had failed to scroll to the bottom of the Rules tab and accept the terms. That fixed it. Thanks!

1 Like

@agoldina VMs work great and we fully intend to continue to offer this. We are hoping that Gradient will help minimize infra management but totally understand if you prefer the VM context :slight_smile:

1 Like

Thank you @win I’ve been having the same problem and 'git stash" worked!!!

I’m still struggling with my new machine… I’m unsure why I can’t connect to Jupyter Notebooks in my browser as it seems to be installed and working. But I was able to finish my work on my old machine so it’s not a complete loss this week. I’ll keep looking into it.

FWIW updates to the library are working again (for me at least) on Gradient.

Miraculously everything works for me too. No idea why. I’ve just been updating it all until it worked.

1 Like

I was having the same problem, here’s how I got it to work.

  1. Delete “sudo” at the beginning of each line and run that cell.
  2. Restart kernel (kernel -> restart from the menu).
  3. Run all the cells from the top.
1 Like


How to download the file into my local system from paperspace server.

Hello - I am unable to start my Jupyter notebook. Per the screenshot below, the status says “Error” each time I try to start my notebook. The error message says:

“Error pulling image ‘’: Error response from daemon: Get net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)”

I’ve also submitted a support ticket to Paperspace directly. What can be done to fix this? @dillon


1 Like

Give it another try. We had a network blip that lasted a few minutes and affected a small number of machine but it looks like it has been resolved!

I’m having a very similar problem now!!

Thanks Dillon. I re-tried and mine is working now.

@dillon This is not working…

Bad news: It will start one of my old machines - which doesn’t do me much good!! I need the recent one!

1 Like

… and now it’s taking longer to error out - 8 minutes

1 Like