Platform: Paperspace and Gradient ✅

They were working fine before (updating the course) FWIW.
Deleted my actual VM when I started the current course cycle.

How are you saving your work? Previously I created a separate git repository for my notebooks but I’m a little confused as to how to do that with the notebooks - can I clone my repo into storage?

was doing stash/pop and saving copies of the NB
The entire experience has been somewhat janky though, FWIW. I may just go back to a VM.

Yeah I’m hesitant to do just the notebook… I know it’s set up but with all the tweaking I’ve had to do with my vm (since I chose the wrong one!) I feel I can get one set up. Already requested the P5000.

Some word from the Paperspace people would be good… I just want to hack :slight_smile:

1 Like

Has anyone been able to get the lesson 2 planet dataset from Kaggle? I get “403 - Forbidden” which I assume is a Gradient problem since other people seem to be able to get the dataset.

Were you able to get the planet dataset downloaded? I get “403 - Forbidden” when I run it.

Noticed I experience this when I make changes like creating a notebook and saving, but I get around it by doing git stash and then a git pull in the course-v3 folder on terminal.

Really dont know why it works


Paperspace site is down??? I get

Error 504 2018-11-08 04:30:05 UTC

Gateway time-out

Help!! @dkobran @dillon

Now the site is back - sort of - but but my notebooks are gone, payment method is gone, can’t log out…

Now it’s

Error 504 Ray ID: 476560322d159b9f • 2018-11-08 04:43:55 UTC

Gateway time-out


and now it’s back, with the banner:

Alert: Paperspace is getting updated! During this process there is a chance you will be disconnected for a minute while we upgrade your machine.

But it was about 15 minutes… would have been helpful to see the banner earlier! and it shows my machine has been running for 30 minutes!!

@ricknta : Did you go to Kaggle competition page and accept the rules?
Something like above.

1 Like

You’re right, that’s what I had been missing - I found there’s a topic for the Planet nb so posted this problem over there:

and got the same answer there. I had failed to scroll to the bottom of the Rules tab and accept the terms. That fixed it. Thanks!

1 Like

@agoldina VMs work great and we fully intend to continue to offer this. We are hoping that Gradient will help minimize infra management but totally understand if you prefer the VM context :slight_smile:

1 Like

Thank you @win I’ve been having the same problem and 'git stash" worked!!!

I’m still struggling with my new machine… I’m unsure why I can’t connect to Jupyter Notebooks in my browser as it seems to be installed and working. But I was able to finish my work on my old machine so it’s not a complete loss this week. I’ll keep looking into it.

FWIW updates to the library are working again (for me at least) on Gradient.

Miraculously everything works for me too. No idea why. I’ve just been updating it all until it worked.

1 Like

I was having the same problem, here’s how I got it to work.

  1. Delete “sudo” at the beginning of each line and run that cell.
  2. Restart kernel (kernel -> restart from the menu).
  3. Run all the cells from the top.
1 Like