Platform: GCP ✅


(noskill) #355

Hey vijay,
I just tried the instructions on my local machine, I am getting a new kernel under kernels option. You might me doing something wrong. Can you explain me the steps you are following in detail.


(Vijay Narayanan Parakimeethal) #356

Hi,

When I do this step, I get to see my kernel. But when I try fastai.version it gives me the latest version number. the steps are as follows:

  1. conda env create -f environment.yml (‘environment.yml’ is the file in the old fastai for creation of fastai GPU environment)
  2. This creates an environment called fastai
  3. Then I do “python -m ipykernel install --user --name fastai”
  4. I can see an environment called fastai. I open a notebook in this environment and type “import fastai; print(fastai.version)”
  5. I can see version as 1.0.18

(noskill) #357

Hey,
Why don’t you try
pip install fastai==0.7??
This will give 0.7 version.


(John Lambert) #358

I just upgraded my account, but am getting the same error.

Error: The zone ‘projects/divine-outlet-218301/zones/us-west1-b’ does not have enough resources available to fulfill the request. Try a different zone, or try again later.

@adpostma thanks for the suggestion, though. It’s going on three days now that I’ve been unable to spin up my GCP instance. I was hoping that this would sort of resolve itself. It sounds like others are having similar problems (@NandoBr), even after switching zones. I’m still relatively new to all of this, so any advice would be much appreciated.


(Vijay Narayanan Parakimeethal) #359

How to use that in a different conda environment? Also how can I ensure that it does not corrupt my existing V1 in the base and install two versions of pytorch.


(Newton Mwai) #360

Hi, please help out. I can no longer start my instance, when try it says:

Starting VM instance “my-fastai-instance” failed. Error: Quota ‘GPUS_ALL_REGIONS’ exceeded. Limit: 0.0 globally.


(Arunoda Susiripala) #361

search this thread. You can see the solution.


(Newton Mwai) #362

Thanks!


(rares t) #363

@Czechcheck thank you for the credit!


(Madhur Jajoo) #364

Thanks a lot for the credit


(Ad Postma) #365

Thanx Czechneck. Much appreciated!


(Khanh K Thai) #366

Hi Allan, I’ve tried your instruction but it did not work on my end. I was frustrated and decided to delete my instance and create another one. I am able to open my notebook now. Thanks for your help!


(Efunwande Osoba) #367

Is anyone else having issues with the kaggle api? I am getting 404 - Not Found errors.


#368

Did you copy kaggle.json file to .kaggle folder and accept competition rules at kaggle website?


#369

Anyone recently observed an increase in time to train an epoch on a GCP instance?By training time per epoch almost shot up by 100%.Have been facing this since past 12 hrs.


(Gabriel) #370

If you are new to kaggle you need to verify your account and then sign up for the competition to be able to access the data.


(Paul M) #371

Unfortunately, I’m getting the error that several others in this thread have also encountered: “The zone ‘…’ does not have enough resources available to fulfill the request. Try a different zone, or try again later.” I’ve tried to restart the instance at many different times over the last 3 hours without success. I read on the “Introducing fastai-shell” thread by @arunoda that @cwerner also had the same problem a couple hours ago, so maybe it’s because the west coast trying to finish up work before the weekend :wink:

I tried to use Jeremy’s tip to move the instance, but I get the following error:

gcloud compute instances move my-fastai-instance
–zone us-west2-b --destination-zone us-east1-b

Moving gce instance my-fastai-instance…failed.
ERROR: (gcloud.compute.instances.move) Instance cannot be moved while in state: TERMINATED

This message is technically correct: I had left the instance on yesterday and it got terminated after 24hours. Is there any other way to access my disk from another location?


(Paul M) #372

FYI, I was able to start this instance again a couple of minutes ago. So maybe it was Friday evening load.


(Krishna Gopal Shrivastava) #373

Thank you Petr Simecek! I received my GCP credit yesterday. This will enable a lot of learning experience for me on Deep Learning through experimenting and I deeply appreciate your nice gesture to help fellow learners. My best wishes!
Regards,
KrishnaGopal Shrivastava


(Sirigudi Tejaswani) #375

I am also getting the same error. Tried creating a new instance in a different zone(us-west1-b), but that is also giving the same error.
Any help would be greatly appreciated