Platform: GCP ✅


(James Juan Whei Tan) #376

This happens every now and then, perhaps give us-west2 a try? It usually works for me when west1 is down.


(Jesús Pérez) #377

It’s possible to change the region/zone when the instance is in status Terminated ?
Previously I was working with gradient solution from Paperspace but my notebooks were deleted after each restart, now after change to GCP platform I can’t start the instance so I’m wondering if I should try with a new platform or create a new instance in a different region/zone. AFAIK in both cases I will start from scratch again


(Yash Mittal) #378

Trying a lot from the last couple of hours but got the same error. Already on upgraded account

Starting VM instance “my-fastai-instance” failed. Error: The zone ‘projects/driven-rider-220513/zones/us-west2-b’ does not have enough resources available to fulfill the request. Try a different zone, or try again later


(Tabish Shaikh) #379

is this due the preempitble type of VM


(Bibek Chaudhary) #380

I created another instance frm scratch with different instance name and zone us-west2-c and it worked


(Paul M) #381

What’s the best strategy for using GCP?


(Akshay) #382

I am getting following error

ssh: connect to host 35.235.85.224 port 22: Connection refused
ERROR: (gcloud.compute.ssh) [/usr/bin/ssh] exited with return code [255]

I have tried:

  1. Creating new ssh key and adding on the server
  2. Using the ‘upgrade’ option
  3. Creating a new instance on a different Gcloud account
  4. Removing --preemptible
  5. Changing zones (to overcome Try a different zone, or try again later error)

Any suggestion to fix this is welcome, thank you.


(Fernando Melo) #383

Maybe, there is a firewall blocking, have you checked that? Try using your phone 4g/3g to test it!


(Fernando Melo) #384

Me either…
I already created 2 instances in different zones, and both don’t start.
Also upgraded my account.
There is no way to make them work!
I opened a ticket at google support and they said they would monitor bla bla bla…
NOTHING
I wish someone from google could monitor this thread and help us…


(Akshay) #385

If you haven’t already then try different zones which support your GPU:
https://cloud.google.com/compute/docs/gpus/


(Arunoda Susiripala) #386

Use us-west2-c with the p4 GPU for now.
That’s the only zone which has resources.


(Arunoda Susiripala) #387

We all know currently we are having some issues related to availability of resources.
So, I just add a new utility on fastai-shell to test that.

Based on my testing with that us-west2-c is the only zone which has resources. That might change.
You can try it yourself by running my utility.

Hope this helps.


(Fernando Melo) #388

Thanks Arunoda. I was able to create a new instance at us-west2-c like you said.
Let´s see how long this one will work correctly…


(Gabriel) #389

Is the issue with available resources still an issue with preemptibility disabled?

Anyone tested?


(Paul M) #390

Yes, the issue persists with preemptibility disabled.


(Akshay) #391

I checked the firewall setting on the server and looks it should accept the connection
default-allow-ssh Ingress Apply to all IP ranges: 0.0.0.0/0. tcp:22 Allow 65534 default

But when I checked with nmap from my local machine I get,
PORT STATE SERVICE
22/tcp closed ssh

The instance is running.


(Jesús Pérez) #392

how do you disable the preemptible option?


(Paul M) #393

When you use the instructions in fastai for creating a new instance, simply skip the --preemptible option in step 3. https://course-v3.fast.ai/start_gcp.html


(Jesús Pérez) #394

If the instance is already created is there a way to change it?


#395

Even when you seem to get the instance going somehow I feel the compute is slow.Is anyone else experiencing that?