Platform: FloydHub ✅

For help with FloydHub, please ask here.

@redeipirati and @whatrocks from FloydHub are here to help you.


If any students try this, please let me know. I haven’t got any 1st-hand experience myself with FloydHub.

Hi Jeremy,

I frequently use floydhub, I’ve run the notebook you covered in class and tried my own problem using the same. They work out alright if i make the necessary installations in the cells:

!pip install torch_nightly -f
!pip install fastai
!pip install fastai --upgrade
!pip show fastai


Without the steps i mentioned before data.classes method and the function ImageDataBunch.from_folder don’t seem to be working in floydhub.

data.classes throws a Nonetype error
ImageDataBunch.from_folder returns an empty object

Even with the floyd requirements file.

Ah, I believe that I need to adjust the instruction guide then to have the user either do what you suggest by updating the fastai library each time the Workspace is live, or by specifying the latest current version of fastai in the floyd_requirements.txt file. I’ll make this adjustment soon!

I had thought that pip would have installed the latest version of a package when you don’t specify a version number, but because our PyTorch image is already including an earlier version of fastai in the image it doesn’t seem to be kicking off an update.

1 Like

I am running into an issue with floydhub where in my GPU instance using the techniques from the course on a dataset I created I only get a few small spikes of GPU utilization training a resnet 34 no matter what batch size I have. The setup is that I created a Floydhub Dataset from a Kaggle competition dataset and I mount that into my workspace. I did some initial work on getting the datablock api correct in a CPU instance, and then restarted in GPU to do some training. I tried upgrading to the latest fastai library explicitly and that did not help any. Thoughts?

Hi @redeipirati and @whatrocks,

I am trying to deploy as a REST API the repository described in this post on the forum using FloydHub.

Following FloydHub’s tutorial, I think I managed to deploy the repository because I received a success message in the console, and see the serving instance running when I go on the platform. However, when I try to test the API using:

-o out.json 
-F "file=@./face.jpg" ## My service endpoint URL

I get:
curl: (92) HTTP/2 stream 0 was not closed cleanly: INTERNAL_ERROR (err 2)

Any idea what’s the issue here, and how I can solve it?


Hi, I’ve been using Floydhub up through the Lesson 3 Planet notebook without too much issue, but in this lesson I’m having major problems. I have pulled the latest notebooks.

  1. Getting 404 for the data download cells from Kaggle - mitigated so far by downloading direct from Kaggle and uploading to the right directory
  2. Blocked by inability to install 7zip. Both Sudo and Conda versions of the install don’t work. Can’t seem to find the right documentation. I can’t seem to get conda working on Floydhub at all. Using the sudo command yields “E: Unable to locate package p7zip-full”

Has anybody had more luck either getting Kaggle to work with Floyd or getting conda or 7zip to work with Floydhub?