Paperspace setup help

Paperspace seems to be having a lot of issues with the console timing out or the GPU drivers not working. I have spoken to their help personnel several times about the problems but they haven’t been able to fix them. I’ve spent hours and tried three different instances so far. Perhaps you can update your recommendation for using them, instead steering people towards AWS or Google? @jeremy

1 Like

Hi, I followed the getting started guide, and I was able to setup the machine properly on AWS platform, very well!!, But now it seems like paperspace is the way to go… I’m having issues entering the credit card at their site… Can we still use AWS platform? Should I just execute the script on the AWS machine? Is compatible? I created the instance from the ami: ami-bc508adc… therefore is GPU capable… not sure about any other constraint?
Thanks in advance.

I’m trying in the AWS cloud… since here I have the machine already configured:
git clone
cd fastai
conda env update
… after a while… this error shows:
LinkError: Link error: Error: post-link failed for: conda-forge::widgetsnbextension-3.2.1-py36_0

Any idea? Thanks in advance…

1 Like

If you are planning to use paperspace, I suggest not creating a machine. They have an option to just use a preconfigured notebook on the left-hand navigation menu once you have signed up already. One of the notebooks is already preconfigured with fastai. I just started the K80 instance (90 cents per hour) and it’s working quite well.

Did you choose: Paperspace+Fast.AI?

Yes, I did.

As @dkobran and @gwenf mentionned above. Paperspace just have a super handy option for FastAI learner - Gradient.

I never used VM but I think Gradient have some advantages. You don’t need to wait for approving the type of machine now. You can choose any type of machine when you open a new notebook. Sometime you need to wait a little bit depends on the current capacity. For my case, it’s not too long (5 or 10 minutes)

You can save money by switching between different kind of machine. For me, I do all the configurations, data processing, …, all stuffs can do without a GPU on C2 machine and it’s 0.009$/hour. Then when I need to train model, I switch to GPU+ (P4000).

You are free of charge for storage. If you save your new data in /storage then it’s saved in the data region.
East Coast (NY2) - GPU+, P5000, C2, C7
GCP West - K80, P100, TPU
Means that if you save you data in C2 machine. You can find it again in a GPU+.
The limits are 1TB in East and 250GB in GCP West. So it’s huge in my current state.

You have a 10$ with the promo code for Fastai learner. FASTAIG5H7 Gradient_promocode

You can also accumulate your credit when sending a referral code for new user of Paperspace. So you will get 10$ and your friend 5$.

My referral code so we can both accumulate credit :grinning:: XHMDK0X

Hope that helps.


Also having the same problem.

Like previous poster, for whatever reason when I (laboriously) typed in the pw it worked!

Okay, lower down it says to try typing in the pw instead of copy-paste. That seems to have worked for me.

Why do I have Windows machine not Linux??

For some reason ubuntu 16 and template are not available to me. I’ve sent request but didnt see others with same problem

Hey @dhoa, how long did it take you to get verified to use the public or even linux templates? They have this weird restriction that you can’t use other non-windows machines unless approved and frankly it’s the only reason I’m not moving onwards with the course.

i didn’t use VM but only Notebook in Gradient and it didn’t have the verification step at all. I got access directly to the course. No waiting time.

You can follow the instruction here: Fastai with Gradient

I think if you want just concentrate on the fastai course and don’t care about all the set up machine, configuration step. Gradient is good choice.

Hope that helps

I got the same error. Have you figured it out? Thank you.

Yes, I got it to work. I just skipped the lines that errored which were basically coping system directories over and everything still worked. I could run all code and develop and didn’t notice any difference.

I think the errors are a result if Paperspace changing their default GPU and Ubuntu 16.04 image

I was setting up someone’s system using the paperspace bash file, and they didn’t have git on it which stopped the process. It would be great if you add git to apt installs just in case.

I understand that part, however how is spinning up an instance of a jupyter notebook worth it, if it’s not for heavy lifting? Might as well use my laptop_run_instance until the point I want to do the heavy computing stuff on the cloud_instance?

You can choose the type of the VM machine when you open a notebook. With a K80 machine then I think it’s quite OK for doing deeplearning.

You can choose a cheap machine when doing the light computing (C2 is just 0.009$) then when you want to doing heavy computing, just stop this one and open a more powerful machine.

I’m unable to access the fastai machine. I requested for access 20 days ago and wrote to them that I want to use it for this course.
Any advice?

Thank you for your reply. But How did you skip those lines?
Any modification to the code “curl | bash”?

Thank you.