Paperspace, out of disk space due to /dev/mapper/dev/dev--u16--cpu--v-root

My paperspace Ubuntu machine is complaining due to a full disk. I do not have a lot of data so that is a bit strange.

I ran ‘df -h’ to check where the data is used:

So some /dev/mapper/dev/dev–u16–cpu–v-root file is eating up all the space. Trying to find out what this actually is I ‘ls -l’ it

So some dev/dm-0 file is taking up a lot of disk space. How can I fix this?

Thank you


I have been on the hunt for what uses this storage space.

So something in the home folder


Digging deeper, into the paperspace folder, which is a dead end. What is in in there that uses all this space but doesn’t show itself? Also ‘ls -l’ has no results.

I am getting pretty desperate at this point.

1 Like

I had a similar issue just a few days ago. For me it came up because I had started with low memory and later upgraded and had not mapped the additional space inside the VM.

Not sure if its the same case with you. Anyway, support was quite fast to help out.


Thanks for the reply, but I haven’t upgraded. In general I have used very little space and all the standard temporary folders, logs and user data looks pretty normal.

I’ll try send paperspace a message and see what they have to say about it.

I had the same issue. Thank you for posting the link and that saved me.

1 Like

Have you solved the problem? I encountered the exact same problem and I did not upgrade.

Hey I’m also having a similar problem- any updates? Did you figure out what was eating all your storage in the paperspace file?

What finally worked for me was emptying the trash files:

rm -rf ~/.local/share/Trash/*

I have had this exact same problem a bunch of times, and keep forgetting that this worked the last time. I never actually realized that linux had trash files like this that needed ‘emptying’? Anyway, hope this helps someone :slight_smile:

1 Like