Paperspace: Jupyter notebook server setup

Thank you @marvin. I have already AWS, and had some errors on the old AMI with the current git repository, so I was waiting for Jeremy to provide us the new ready to use AMI. Meanwhile I was using paperspace, since it was promoted as having the best rates.

Probably I will go for AWS as well in the future, but now this behaviour is annoying - moreover because I change nothing to the machine.

I have checked the opened ports with, the following command (see pic in previous post) and the port 8888 seemed opened.

netstat -ntlp | grep LISTEN

Hi @marvin , Dillon here from Paperspace. That is definitely not normal performance and we don’t throttle any bandwidth. Would you be able to send us an email to with your machine id so we can make sure everything looks good on our end?

Also, we do have shared drives and we can set you up with one of those as well. Sorry for the issues I hope we can get to the bottom of it!

Hi @alessa can you send us an email to with your machine id so that we can get to the bottom of this.

Hey @dillon thanks for your reply!
I already contacted the support through the online form (told my issue, give the id number) that you are providing, I think is the same as sending an email to support@, isn’t it?

The only thing that I changed, but it has nothing to do with the current machine, is that I had second free machine which I didn’t use it - I created only for test 10 days ago, and today I deleted “deactivated” it.

thank you for sharing


yes setting up AWS takes a bit of hazzle. However, I did it today and running Week 1 notebook on a Volta, which is totally nuts because everything flies. However, there is concurrency bug that occasionally slows things down, so you can circumvent it by preventing subprocess spanning:

@marvin @alessa There is an update on that front. Pull latest code from github. Jeremy has fixed the issue of locking. (details in this thread: Very slow loading of the Convnet pretrained model on lesson 1)

Thank you, the latest pullt from Github is SO MUCH better performance wise. Learning rate has effectively doubled!

I wouldn’t expect the Voltas to be much faster than Paperspace’s high-specced GPUs. Paperspace seems to have the best performance vs $ at the moment, AFAICT.

@jeremy I was referring to the latest pull from github. just updated the post a moment ago. I guess the relative change is the same for all GPU’s. With Paperspace, I just got an unlucky image or day, which should be fixed soon.

Thank you @dillon

The issues are solved & I updated the post. Thanks your help

1 Like

Here is a promo code for 10 dollars “SP3MJD”.

Promo code for 10 dollars - “3KM29VE”

I am unable to open jupyter notebook even after sudo ufw allow 8888 and ssh tunneling.jupyter%204

Here are the step by step details to get $25 in free credits on Paperspace:

Step 1. Sign up using a referral code and you get $10-credit, and the person whose referral code is used gets $15 credit (as of this writing). Below is my link, but you can substitute it with any other referral code mentioned in this thread.

Step 2. Complete the account opening and validate your email address.

Step 3. Apply $15 credit to your account:

Go to:

scroll down to “Promo Code” and enter FASTAI15

Now you have $25 in free credits.

I noticed that paperspace is extremely slow (slower than my laptop) when trying to run CNN model. Any suggestions of why would this be the case. It’s the first time I use paperspace.

I enabled international transactions but still doesn’t work. what am I missing?

have the same problem, how did you solve this?

I switched to aws :slight_smile:

1 Like

ahaha, the best advice.