Paperspace Error

(Bernardo Roschke) #1

I tried searching but could not find a thread. Getting an error setting up the files with the curl command.
curl http://files.fast.ai/setup/paperspace | bash

rm: cannot remove ‘/etc/apt/apt.conf.d/.’: No such file or directory

Anyone know how to fix this?

3 Likes

Paperspace issue conda
(Dillon (Paperspace)) #2

@bernardo can you try a sudo apt-get update and a machine restart? If you are still seeing issues definitely send us the machine info (base OS, type, etc) to support@paperspace.com

0 Likes

(Bernardo Roschke) #3

Hi @dillon,

Thanks for the reply. I thought I needed to run the curl script within the Fastai template. After I realized my mistake, everything was already set up as needed. Thank you for the response. I tried to delete my post but couldn’t see how.

1 Like

(gautier) #4

I have exaclty the same error when I run:
curl http://files.fast.ai/setup/paperspace | bash

How do you fix it?

0 Likes

(Bernardo Roschke) #5

If you’re using the fastai template, you don’t need to run this part. Everything is already installed. Just move ahead. :smile:

2 Likes

(Brendan McGivern) #6

For those that are using an AWS instance like myself (p2.xlarge), I ran into this issue as well. I just removed the following line from the bash script:

sudo rm /etc/apt/apt.conf.d/*.*

Created my own bash file on the server and ran the script. Fixed the issue for me.

1 Like

(David ) #7

I found a simple fix to be just create a dummy file in the /etc/apt/apt.conf.d direction

sudo touch /etc/apt/apt.conf.d/test.txt

Then re run the original command and now something is in there to be deleted.

18 Likes

(Kamal Tanwar) #8

Thanks for the quick fix! worked like a charm

0 Likes

(Abenezer) #9

@dleacockDavid
Thanks, this one line of code solve the problem

0 Likes

(Prasad S) #10

Amazing… worked like a charm!

0 Likes

(Aman Arora) #11

Thanks!

0 Likes

#12

Thanks very much!!

0 Likes

(PAS) #13

I use fastai template but I do not think everything is already installed. For instance, there is no data folder.

0 Likes