Nvidia-smi: command not found

Good afternoon:

After successfully connecting to my p2.xlarge instance.

I entered the “nvidia-smi” at the $ command prompt and get “command not found”.

ubuntu@ip-172-31-31-165:~$ nvidia-smi
nvidia-smi: command not found

I believe I am missing something very basic here.
Perhaps a file path?
Or is there a command I can execute at the $ prompt during my current session?

I have the same issue (command not found) when I attempt to execute the “jupyter notebook” at the $ prompt.

I did a search within the forum discussions and “Common Problems Section” and was unable to locate a similar problem.

Thanks in advance to all. Much appreciated.

Best regards,

Hi Bob looks very much like you have not set up the environment, search these forums for the AWS scripts should be in the early lesson wikis also the scripts are also in the Build your own server forum. As noted by many build your own server has cost and performance benefits.




I’m having the same problem. Did anyone find a solution? Thanks.

Your Instance isn’t configured properly.

Similar problem with us-east-1

  1. It looks like the image needs updates.
  2. Got the same error message the first time that I tried the command.
  3. Different error the second time.
  4. Connected to the jupyter server successfully, but import theano gave an error suggesting that there is no gpu.

WARNING (theano.sandbox.cuda): CUDA is installed, but device gpu is not available (error: Unable to get the number of gpus available: no CUDA-capable device is detected)

See below:

The authenticity of host ‘ec2-34-238-179-241.compute-1.amazonaws.com (’ can’t be established.
ECDSA key fingerprint is SHA256:SsDA2vPjSSlKgiQnr01MlQ33ZxFpzl8INLbx5hOG/1A.
Are you sure you want to continue connecting (yes/no)? y
Please type ‘yes’ or ‘no’: yes
Warning: Permanently added ‘ec2-34-238-179-241.compute-1.amazonaws.com,’ (ECDSA) to the list of known hosts.
Welcome to Ubuntu 16.04.1 LTS (GNU/Linux 4.4.0-36-generic x86_64)

Get cloud support with Ubuntu Advantage Cloud Guest:

7 packages can be updated.
4 updates are security updates.

Last login: Sun Oct 16 02:04:33 2016 from
ubuntu@ip-10-0-0-13:~$ nvidia-smi
nvidia-smi: command not found
ubuntu@ip-10-0-0-13:~$ nvidia-smi
Failed to initialize NVML: Driver/library version mismatch
ubuntu@ip-10-0-0-13:~$ pwd

I was experiencing the same problem on setup, but the solution was straightforward

sudo apt-get update
sudo reboot

and then it was working fine

This may be a bit late but there are now 2 options available from AWS to this problem.