Notebook courses/dl1/lesson1.ipynb is not trusted

This is what I keep getting when I try to run the first of the code snippets …

Notebook courses/dl1/lesson1.ipynb is not trusted

I have no idea what is going on.


Does this prevent your code to run? or you are just annoyed with the “trust” message?
This is not an issue in running the code. So nothing to worry about.

Thank you for the response, but I don’t think the code is running.
Especially for the part where I am expecting to see the result:

But I see nothing… nor do I see the above code in the terminal

The above is what you should see. You check if cuda is available and it responds that it is by output = Ture. All is good as far as i can see from the screenshot.

In Jupyter notebook you put your code in the input cell (In), you run the cell with Shift+Enter and you get output below (Out). For example:

Simply change your directory permissions…


Just hit the not trusted button and click to reload the notebook in trusted state again


In the terminal with the nbs director,

Type in bash

jupyter trust *.ipynb

This is what I got when I ran the above code per the class instructions:

What am I doing wrong?


It means you don’t have the pytorch ‘torch’ library. Are you using AWS, Paperspace or Crestle or your own computer? Like i am on Paperspace and fastai image has all needed libraries pre-installed.

I am on and have all of the instructions, except the video says to choose the first machine at $.40 but that was not available so chose the next one after confirmation from Paperspace support. I ran through the steps again and now I get the expected result:


Thanks to both Miwojc and Aditya, the trust issue is gone and I have been able to proceed to the next steps.


Try digging in a bit more …
Will help you learn by yourself…
Pleasure to help