No space left on device error

This might be a stupid question, but I’m having a error with no space in paperspace.

I was downloading the planet data from kaggle with
kg config -g -u 'xxxxx' -p 'xxxxx' -c 'planet-understanding-the-amazon-from-space',
and had a error [Errno 28] No space left on device

So inside the jupyter notebook, I manually deleted the data downloaded in /data folder, and some other additional datas I’ve downloaded from kaggle for more space.

However it still says there’s no space left in the device. I’m new to all this jupyter environment, so am I doing something wrong? Also, is there anyway to check the remaining space in paperspace?

1 Like

You filled up the space on your drive with the dataset. Delete the large files (I think they’re .tiff, you can see which using ls -lh), and only download the jpg versions (and the labels). With the official kaggle api you can do that with -f filename, I’m sure the kaggle cli has something similar.

I’ve already tried to delete the files that took up lots of space, but when I tried to delete the files there was a error

and the file wasn’t deleted. If I refreshed the page, the file was gone, but it still said I was out of space.

Try rm in bash, it looks like jupyter is trying to send it to the systems trash rather than deleting it outright.

I’ll try, but how can I erase the ones that are already in the system trash? Any ways to empty it?


rm -rf ~/.local/share/Trash/*

If you want to run that from the notebook don’t forget to put a ! before it.

6 Likes

Thanks!! I actually just made a new Paperspace Machine and solved it, but it actually helped me a lot!!

Hello! I know this is an old thread, but wanted to post about a new solution I found regarding no space error (err no 28) on an Amazon EC2 instance.

I recently received this error after completing part 1 of the 2019 course and updating Conda when returning to instance to begin part 2.

I was able to follow the tutorial below step by step and fix the problem, increasing my disk space to 300gb from initial 75gb. DISCLAIMER: I do not yet know what effect this has on total cost of EC2 instance. I think I see that cost is .10 cents per gigabyte per month, so this would be a base cost of 30.00 per month, but again I am not 100% sure of that.

Here’s tutorial: http://www.messor.com/increase-disk-size-for-an-ec2-instance-in-aws/

Patton

I’m not sure if it is related, but I got an error when opening Jupyter Notebook: “Bad config encountered during initialization”.

I fixed this with 2 commands:

  1. updating jupyter: “conda install jupyter”
  2. installing jupyter environment kernels: “pip install environment_kernels”