No module named 'fire'

I am running the 00_exports.ipynb notebook, and I cannot use the notebook2script.py script.

When I run !python notebook2script.py 00_exports.ipynb, this error is shown-

ModuleNotFoundError: No module named 'fire'
Full error message
Traceback (most recent call last):
  File "notebook2script.py", line 3, in <module>
    import json,fire,re
ModuleNotFoundError: No module named 'fire'

I have chosen the safest environment to run old notebooks- a predefined container in Paperspace.

What do I do about this?

1 Like

Had the same problem once. I went down the tree of modules where it was first defined and as I remember it was not doing a significant job so I commented it out where it was first imported or defined. Works well for the rest of your journey.

I just ran

!pip install fire

And that solved it for me. I should have never posted this topic. I did it because I thought I am in dependency hell again after I tried to do the old ML course from fast.ai. But I googled the library. It seemed active, and I realized my mistake. I just installed it and the code ran correctly.

2 Likes