Need help: This cell seems to be taking forever to unpack data with 7zip

I’m having issues with unpacking data in Lesson 3 Planet notebook.
I’m running the cell with the code:
! 7za -bd -y -so x {path}/train-jpg.tar.7z | tar xf - -C {path}

The problem is it’s taking forever to unpack the data. The cell has been running for more than 15 minutes now. How much time is it supposed to take. I’m using Paperspace Gradient with P5000 GPU.



@akshaych I am also facing the same issue. Have you got any solution for the mentioned problem?

@rijul I just went through it just to see for myself how much time it takes to execute this cell. It took me about 19 minutes on the P5000 GPU on Paperspace Gradient.

Okay. So this not a bug but an unusual exercise to attempt. BTW I am using P4000 Gpu on paper space gradient. Don’t how much time it will take me to run that cell.
Thanks! @akshaych

1 Like

@rijul No problem, mate!
Have you tried to execute the cell again? I suppose it might take about 25-30 minutes.

@akshaych Hey, I have not tried after I got stuck but possibly will do today and will tell how much time it took for me to execute it.

Hello I am trying to get started with FastAI. I am stuck at cell #id first_training in lesson 1 notebook 01_intro.ipynb on paper space gradient. It takes forever to run and actually stays stuck at 0%.

My config : P5000

Any idea how to unlock the situation ?