Nbdev v2 launched

Got it, Thanks Jeremy.

I have another question about #|echo: false. I think it should work as below.

However, when I tried it with my nbdev project, it didn’t hide the input.

I tried both #|echo: false and #|echo: False. Neither work on my side.


Sorry, no more problem! Now it is working.

1 Like

I have a strange behavior of doc in nbdev project.

but after I installed with conda install -c fastai nbdev. The problem is gone.

After installed nbdev 2, it seems importing nbdev_export in jupyter cell does not work anymore. But everything else works fine.

Check the version. I’m not sure you’ve got the latest.

1 Like

You are right, it is working now!

I made the change on 07_meta.ipynb in my fork of fastcore, and after I run nbdev_preview, I run git diff and there are some auto changes to _modidx.py file. Should this be happening?

Then I run nbdev_preview and found the difference on the web

When I run git diff, I found auto changes to _quarto.yaml below:

And there is auto changes on the 07_meta.ipynb file as well:

How should I deal with them? Thanks!


Should I simply make the change on 07_meta.ipynb and push without running nbdev_prepare so that there won’t be those auto changes?

1 Like

You should run nbdev_install_hooks. That will remove that metadata added to the notebook for you. Also make sure you update to the latest fastcore, nbdev, and execnb versions. Thanks for being so thorough!

2 Likes

I have done all the updates and installs. However, right now, I got the following error message when running nbdev_preview:

I tried to pip uninstall nbdev and reinstall it again, and pip install -U nbdev and run nbdev_install_hooks. Still got this same error message. What else should I try?

Can we convert ipynb file to markdown file, and from markdown file to ipynb file using nbdev command?

I found this post in 2020 about using nbdev_nb2md to convert from notebook to markdown. But I can’t find any such command from nbdev2.

I have deleted mambaforge folder and reinstalled everything, but the error persisted.

I just released something which should fix this - please try updating nbdev.

1 Like

I tried it but still not working for me.

First, I updated nbdev

Second, I ran nbdev_prepare, no problem, but nbdev_preview get me the following error message:

In order to see whether nbdev_preview can work in the end, I comment out all the places where I import and use my lib debuggable, but still can’t get nbdev_preview to work properly.

As the error says, it can’t find debuggable.utils. You need to install it. (eg “pip install - e .”)

1 Like

Yes, pip install -e . solved the import problem, but I still got this error. when running `nbdev_preview’

—-
Maybe I accidentally deleted some file? I guess I could do nbdev_new to recreate the project

If you have ever wanted to use nbdev on gitlab.com then here are my notes on setting up nbdev v2 on gitlab: https://robtheoceanographer.com/gitlab-nbdev.html

Thanks again to Jeremy and Hamel for your quality work - nbdev is so well built that is easy to understand what it is doing and to hack on it for a gitlab port. I am always impressed with the work Jeremy does and with the brilliant people in the community that surounds him.

3 Likes

I create a new nbdev project from an empty repo and put utils.ipynb into the repo, and it works. But when I put use_kwargs.ipynb back in, the same error appeared.

Then, I noticed one thing which is the key to cause the error. I have #|default_exp utils without actually #|export anything. After I removed #|default_exp utils, no more error.

I have not tried it yet, but it seems quarto has figured it out

Hi,
I enjoy using nbdev. With the new update, version 2 do we have any way to install Quarto without using sudo?
Thanks

I’d suggest checking quarto.org. I haven’t tried that myself.

Hi,
Thank you for your reply. If I want to install version 1 of nbdev. What can I do for installation? Thank you