`nbdev_preview` does not work?


I’m new to nbdev but considering using it for my project. Thanks for the great project!

Somehow nbdev_preview does not work in my project as well as in the tutorial cards_deck repo. Unlike the youtube video tutorial, nbdev_preview doesn’t generate quarto previews.

This is, for example, what I did. First, I clone cards_deck repo and remove _quarto.yml according to this post. And, the following is what happens with nbdev_preview:

~/cards_deck main❯ nbdev_preview                                                                                                                                     7s
Preparing to preview

Watching files for changes
Browse at http://localhost:7205/
GET: / (404: Not Found)

Am I missing any steps?


The preview doesn’t seem to work on my mac environment (macOS Ventura). When I tried it on a Linux machine, it worked as expected. I don’t know what’s wrong with my mac environment, but there seems something wrong with it.

Any way to debug my issue? nbdev doesn’t seem to have an option to run it in a verbose mode.

I found out that this happens when a project folder has a parent folder starting with dot(.), which not only nbdev but also quarto ignores. This happens with other packages and so I decided take out my repos out of a folder starting with ‘.’.