Multi-label (NOT one-hot-encoded) tabular data

I tried running the code from the fastai docs Tabular Core, “NOT one-hot-encoded” section but dls = to.dataloaders(bs=64) gives me:
Could not do one pass in your dataloader, there is something wrong in it.

Furthermore, dls.one_batch() gives the error:

~\.conda\envs\aienv\lib\site-packages\fastai\ in tensor(x, *rest, **kwargs)
    131            else torch.tensor(x, **kwargs) if isinstance(x, (tuple,list))
    132            else _array2tensor(x) if isinstance(x, ndarray)
--> 133            else as_tensor(x.values, **kwargs) if isinstance(x, (pd.Series, pd.DataFrame))
    134 #            else as_tensor(array(x, **kwargs)) if hasattr(x, '__array__') or is_iter(x)
    135            else _array2tensor(array(x), **kwargs))

TypeError: cant convert np.ndarray of type numpy.object_. The only supported types are: float64, float32, float16, complex64, complex128, int64, int32, int16, int8, uint8, and bool.

The code from the “one-hot-encoded” section however works fine (also on other datasets that I have tried out).

Obviously I’m doing something wrong but on the other hand, I can’t understand why it should work at all. How can TabularPandas possibly know how the targets have been arranged (there’s no delimiter defined, that is, there’s nothing like label_delim=' ')?

My question:
Is anyone able to reproduce the code for the “NOT one-hot-encoded” section without the errors above?
If yes, can someone also explain HOW this works without having a ``label_delim=’ '` or something like that?

Looks like no one else has this problem?! :confused: