Mount failed: invalid oauth code in Colab setup

Hello All,

I am trying to run 01_intro.ipynb in Colab and I have followed the using Colab guide.

When I run all cells I get the following error:

ValueError: mount failed: invalid oauth code

When running the first cell:

!pip install -Uqq fastbook
import fastbook

Thus far, I have tried running:

!pip install pandas==1.1.0
!pip install fastai2
!pip list

and I have made sure Colab is using the GPU.

Does anyone know how to remedy this problem?

That doesn’t really tell us much - could you try running cell by cell or telling us which cell fails?

Hi KamKam

Were you prompted to enter your Google user and password so the colab server can get to your Google drive.

Regards Conwyn

I got the same error: “ValueError: mount failed: invalid oauth code”

I ran the following statements:

!pip install -Uqq fastbook
import fastbook

the copy button on google is not working I think. I manually copied the link and it worked.


Hello KamKam hope all is well!

I have been using Colab for over a year now and have noticed that in he past two weeks the connecting to the drive has become intermittent.
Like changezakram I have noticed that the copy icon is not working correctly, sometimes it appears to only copy part of the key. I have also been copying the key manually and sometimes have had to repeat the process 5 or 6 times before it worked.

Hope this helps.

Cheers mrfabulous1 :smiley: :smiley:

1 Like

i got fit.3 get some error:

I wish someone would tell me why I’m wrong,thanks