Module Not Found Error: No module named 'bcolz'

I am getting ModuleNotFoundError: No module named 'bcolz' when I want to run the textbook in lesson 1 containing from fastai.imports import *.

I already tried everything in here ModuleNotFoundError: No module named 'bcolz', but it didn’t work for me.

Try running conda install -c anaconda bcolz from Conda Environment or anaconda prompt(Windows) to get the required library. You can enter conda enviroment by running source activate environment_name (No need of Source in the case of windows)


@gokkulnath thank you for the help. I just had the same problem that popped up after running a git pull and conda env update and your solution fixed things for me.


Hi guys,

had the same error message as above, on my 1st machine

on my first machine, after creating it, i had run git pull and conda env update as shown in lesson 1 video.

so i recreated a machine using the Fastai template but this time i did not run git pull and conda env update, and now i can run all the commands in the notebook without any error. So it looks like the template is set properly, we should not modify it afterwards.

@gokkulnath have you tried running the fastai env on jupyter lab? Everything works fine for me on jupyter notebook but when i try to run the same notebook in jupyter lab i get a no module installed error for bcolz again

@whamp I am not a user of JupterLab. But, I doubt that you are not using the same python environment in JupyterLab as in Jupyter Notebook. Check out whether you are able to see the fastai kernel listed. if yes then choose that kernel and execute the fastai notebooks.

1 Like