Login to Huggingface on Paperspace?

I am having problems using the “notebook_login()” on Paperspace.com. I fill in my Huggingface token and press login and nothing happens. No errors, no nothing. Tried running the next cells using huggingface but this gives errors because it can’t log in to huggingface. Any others with this problem and possible solutions?

1 Like

I have been able to successfully use paperspace, maybe try creating a token again and see if that helps.

you need to log in hugginface and go to the model page and accept conditions. CompVis/stable-diffusion-v1-4 · Hugging Face. then it works fine

Thanks a lot! Still no success though… I just don’t get anything back. Inspecting Network traffic something does happen but no errors seems to occur.

Hi Jesper,

Can you check and confirm that you selected write as the Role of your access token? I was running into a similar issue because I had selected read for the token I was trying to use – once I generated a new one (with the write role) I was able to run through the notebook successfully.

Thanks a lot. Yes I selected write. I now seems to have solved the problem but not in the notebook. I fired up the command prompt in Paperspace and ran the login from there.

Be sure to click the “JupyterLab” icon on the bottom of the Paperspace toolbar. By default they use their custom version of Jupyter which breaks a lot of things (including Hugging Face login apparently), so it’s best to always use JupyterLab instead.


Thanks a lot Jeremy, this was the issue! Now solved.

1 Like