Local Fastpages missing not rendering jupyter notebooks

I somehow managed to get jekyll working with fastpages locally and on the repository. BUT…

My local hosting does not seem to host files from _notebooks folder, i.e., jupyter notebooks. Is there some instructions on how to get it working. So far I have done the following

  1. I have cloned the repo to a local folder
  2. bundle install
  3. Added gem "therubyracer" to the Gemfile
  4. bundle install and then bundle exec jekyll serve

@hamelsmu Can you please point me in some right direction? Thank You.

Note: I haven’t made any changes to the blogposts. Just followed instructions to set it up. I seem to have a similar problem as described later in the post here .

Did you try the troubleshooting steps/guide that you can see from the readme?

Have you also for docker installed as per the development guide in the post you linked to? The stuff which turns notebooks into posts happens in the github actions they refer to in problem number 2.

1 Like

No I have not installed docker… I was holding off on it checking if I need it in the first place. I will give docker a try now. But it looks like a black box and I can’t find more information of what happens in it. Do you know posts where people host without using docker? I can’t find any in the forum.

What do you mean problem number 2? Where can I find this?

When you click your link to the other post you get a numbered list, number 2 says

You can’t turn notebooks into posts without getting that up and running. Honestly it sounds for you personally like you’re going to have to figure out a fair bit of stuff to get this up and running on your local machine and I think you should ask yourself if it’s worth the effort.

If you just want to play around with your site design before you launch it then maybe just do it with the live site before you tell anyone it’s there.

If there is a compelling reason for doing this locally then it sounds like you need to start with that development guide.


Alternatively you may be able to create a script to run locally which mimics everything it does in the gh actions

Yeah… If I have a peaceful workflow why not use docker (maybe for now atleast). Been spending too much time on this. Thanks.

I dont’ know what I am doing BUT…

Got some errors after installing Docker asking to install docker-compose. Followed the website again.

When I ran make server I got “Permission denied” error. sudo make server takes some time but hosts everything properly locally. :slight_smile:

It takes more than 5 mins to host… do you also have the same?

I don’t run it locally

It will take a while the first time, it should cache after that

Tried it three times… takes more than 5 mins. :frowning: