Load_learner library version on windows

hi friends,
got this weird issue, I built a net, put it on render.com and all working great.
Now I want to run it locally on windows, I reinstall my entire Conda to have all the latest stuff,
and I execute my python and I get:

File “app/server.py”, line 31, in setup_learner
learn = load_learner(path, export_file_name)
NameError: name ‘load_learner’ is not defined

The thing is that apparently load_learner is available from 1.40 and Conda has installed for me 1.38.
When I go to Conda´s website, it says that it has 1.46 but when I run the command on windows:
conda install -c fastai fastai

it keeps saying: # All requested packages already installed.

and yet a conda list shows that I have 38, not 40 or 46, which is why I get the
load_learner error

puzzled, any tips? I see no way to bring my windows installation to 40 or 46 so that my code can run load_learner without errors

I ran into this too. There’s something weird about conda updating fastai on windows. I used the suggestion here:

1 Like

Thank you very much KarlH, I found another page with similar fix:
!pip install --upgrade git+https://github.com/fastai/fastai.git
and yeah it worked! thank you :slight_smile: