Lesson 6 rnn error in Gradient-Paperspace _ can't read special character

There is an error when I run the code below in lesson 6 rnn in Gradient-Paperspace

text = open(f'{PATH}nietzsche.txt').read()

And I found this is because there are some specials characters in the .txt file. For example: æsthetical

When I ran this notebook on my own PC, I didn’t encounter that problem so I think maybe there is an mismatch version of environment between Gradient and Fastai.

For now, I remove these special characters and can run normally the notebook but maybe someone can help me to fix it. Thank you

I think you found solution, in sense, that either your env are notebook are not up-to date with master.

Try updating environment, and doing git pull

1 Like

Actually I’m learning on Gradient platform of Paperspace and i’m not sure that I have all the control of the machine. In the interface, it’s just have the Jupiter Notebook.

I tried to open a terminal and update the environment also git pull. However, I failed to activate the environment. The error shown belown

I also tried to fix the problem by doing things suggest in the terminal but not succeed.

Maybe @dkobran can help me on this. Thank you