Lesson 2: 'NoneType' object has no attribute 'c'

#1

On Google Colab, I built a notebook on my own image set using the dog breed notebook example. When I ran learn = ConvLearner.pretrained(arch, data, precompute=True) , I got the above mentioned error (also attached).

One of potential reasons could be that I did not download the weights.tgz file (everything else was done precisely as instructed), so I went looking for it, but it seems to be missing from github (appears like empty drive where it used to be) and http address. Curl in Terminal failed to connect and !wget -O fastai/weights.tgz http://files.fast.ai/models/weights.tgz on Colab got back with “no such file or directory”.

Not sure if the two issues are connected - any advice much appreciated.

1 Like

(Navin Kumar) #2

Can you also check whether you have correctly read the object data
like data.trn_y, data.trn_ds.filenames etc…

This attribute data.c need not be set explicitly, its learned by the fastai API. I suspect there might be something wrong before this call() … If everything seems to be correct to the naked eye, a kernel restart might also be a good idea…even though it can be done as the last option…

It would be better if you post according to the lesson wiki than creating a new topic thread…
For eg. Lesson 2 has a thread created in http://forums.fast.ai/t/wiki-lesson-2
There are higher chances of people responding to the posts posted there…

0 Likes

(Saheed TIJANI) #3

Hi Prosas, did you find solution to this issue? I’m having the same error with the newer cnn_learner. Your guidance will be appreciated.

0 Likes

(Saheed TIJANI) #4

I have figured it out. I should have passed in the DataBunch object as a keyword argument: cnn_learner(data=my_databunch,.......).

0 Likes