Lesson 2: Binder deployment not working with voila

  1. Forked github repo shown in Lesson 2.

  2. Then went to binder and created a binder launch site then got the following error. Also got the same error when I made a different classifier and launched it on Binder

Error:

Anybody knows whats happening? and how to solve it? Some other people have had the same problem and have created issues in the repo of fastai/bear_voila since the last few weeks.

@joedockrill @jeremy any help possible?

1 Like

Following this too. I received the exact same error as well.

I also had this error. This is why I switched to Heroku. There is a pretty good guide on the course page.
With heroku you can enable debug messages in the Procfile, to find out what the error in cell 2 is.

1 Like

Can you paste a link to the instructions? Is it as easy as deploying to Binder?

Thanks.

Here you go https://course.fast.ai/deployment_heroku

ok. thanks. Seems well written, I will try it out in a bit. Wierd there is no Binder there for deployment. :slight_smile:

Thanks Mike! Will give it a shot.

The guides there so far are there ones people have written. I wrote the heroku one having deployed all my stuff there. Someone else wrote the seeme.ai guide after figuring that out.

If you or anyone else wants to add other guides for other platforms you’ve deployed to you can follow the same kind of format (more or less) and submit a PR to the course repo.

Jeremy and Sylvain have enough to do already imo so if you see something you think needs doing and you care enough about it, don’t be shy.

1 Like

Hi @ringoo , I deployed my app, thanks for the requirement.txt and runtime.txt files.

/app/.heroku/python/lib/python3.8/site-packages/fastcore/foundation.py:56: UserWarning: patch_property is deprecated and will be removed; use patch(as_prop=True) instead warnings.warn("patch_property is deprecated and will be removed; use patch(as_prop=True) instead")

Removed the --debug option and that was gone as well
App: https://obama-classifier.herokuapp.com/

@joedockrill thanks for the write up. Your’s along with ringoo’s work was good enough for fastai2

Also had this error. Thanks for your suggestions, I will have a look on Heroku

meinzer1899… It’s not hard at all… Look at what all files whatagame has. I bascially emulated him.

Add --debug to the Procfile to see the errors (If you don’t know how to do it, look at the procfile and history in whatgame's github.

Add the requirements.txt and runtime.txt files (choose the right python version).

and then you are done.

Check this out if things are unclear or give a shout here.

1 Like

You have to take care which Python version is required by your PyTorch requirements in requirements.txt.

If you use https://download.pytorch.org/whl/cpu/torch-1.6.0%2Bcpu-cp38-cp38-linux_x86_64.whl you need python-3.8 (see cp38 which stands for CPython 3.8).

@thetj09 nicely put that into a runtime.txt.

1 Like

it was all @ringoo 's work. https://github.com/mesw/whatgame3