Lesson 11 cannot install fasttext in windows 10 need help

(sathya narayna rao ragunathan) #1

I tried installing fastText in anaconda env in windows 10. I get the following error. can someone help me install this on windows. thanks.

(fastai) D:\fastaiOffline\fastai\courses\dl2\fastText>python setup.py install
running install
running bdist_egg
running egg_info
writing python\fasttext.egg-info\PKG-INFO
writing dependency_links to python\fasttext.egg-info\dependency_links.txt
writing requirements to python\fasttext.egg-info\requires.txt
writing top-level names to python\fasttext.egg-info\top_level.txt
reading manifest file 'python\fasttext.egg-info\SOURCES.txt'
reading manifest template 'MANIFEST.in'
writing manifest file 'python\fasttext.egg-info\SOURCES.txt'
installing library code to build\bdist.win-amd64\egg
running install_lib
running build_py
running build_ext
building 'fasttext_pybind' extension
C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\BIN\x86_amd64\cl.exe /c /nologo /Ox /W3 /GL /DNDEBUG /MD -IC:\Users\snr-work\Anaconda3\envs\fastai\Include -IC:\Users\snr-work\AppData\Roaming\Python\Python36\Include -Isrc -IC:\Users\snr-work\Anaconda3\envs\fastai\include -IC:\Users\snr-work\Anaconda3\envs\fastai\include "-IC:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\INCLUDE" "-IC:\Program Files (x86)\Windows Kits\10\include\10.0.10240.0\ucrt" "-IC:\Program Files (x86)\Windows Kits\8.1\include\shared" "-IC:\Program Files (x86)\Windows Kits\8.1\include\um" "-IC:\Program Files (x86)\Windows Kits\8.1\include\winrt" /EHsc /Tppython/fastText/pybind/fasttext_pybind.cc /Fobuild\temp.win-amd64-3.6\Release\python/fastText/pybind/fasttext_pybind.obj /EHsc /DVERSION_INFO=\"0.8.22\"
c1xx: fatal error C1083: Cannot open source file: 'python/fastText/pybind/fasttext_pybind.cc': No such file or directory
error: command 'C:\\Program Files (x86)\\Microsoft Visual Studio 14.0\\VC\\BIN\\x86_amd64\\cl.exe' failed with exit status 2

(Gerardo Garcia) #2

Have you tried?

conda env update

After you activated fastai


(sathya narayna rao ragunathan) #3

Tried updating and building again. still the same error


(Brian Smith) #4

This link helped me get fasttext going with Windows - https://github.com/facebookresearch/fastText/issues/411

1 Like