Learning rate, training and validation loss are blank

(Obi IK) #1

Hi guys,

I’m working with tabular data from this kaggle competition and I’m trying to find my learning rate and the graph is blank. The train_loss and valid_loss are both empty too, and the accuracy is the same figure every time.

I created the data bunch without error. Does anyone know why this is happening?

0 Likes

(Zachary Mueller) #2

I’d go through your variables to make sure A.) they’re the correct type. And if so B.) find the ones breaking it and fix them if you can, ekse drop them.

1 Like

(François-Guillaume Fernandez) #3

Hi @ikey001,

I had the same issue on lesson1 or lesson2! Specifying the range of LR and restarting the notebook solved the issue for me. I’m not sure of the cause of this, but the only reason I can see for this is that the loss explodes very early because the range starts quite high.

Happy to hear if anyone has a well-grounded explanation!

Cheers

1 Like

(Alan Williams) #4

For me, it was because I had nan in my data. Removing that column solved it for me.

1 Like

(Obi IK) #5

Thanks guys, I looked at the dataset again and removed some features that were empty and it resolved it.

0 Likes