Learner.lr_find() doesn't "finish"


When I run learner.lr_find(), I often see that it doesn’t finish. See the following image for an example:

Over here, the command finishes only after 10.17%. And I’ve seen this in multiple notebooks, not just this one.

  1. I tried restarting the kernel and re-running all the cells but that didn’t help.
  2. I also updated both the Pytorch and Fastai libraries through Conda. That didn’t help either.

As for what I am doing:

  1. I am re-creating the lesson7-resnet-mnist.ipynb notebook from scratch. So, building a image classification model on MNIST.
  2. This is on a Sage Maker notebook running p3.2xl.

Can someone please help?

This is correct. The way the algorithm works is we first start at a lower LR, then move higher until the loss hits a particular threshold speed and it stops. This can happen in 1/2 an epoch, a full one, 1/10th, does that makes sense?

I see.

What does this mean for me? Can I just proceed with what I see?

In other words, is there an error here or is everything okay?

Nope! You can continue with a LR around 5e-2 :slight_smile: