`Learner` has no attribute `export`

Somehow I can’t export the Learner object I created. My version on crestle.ai is 1.0.34

The Learner object in my source has no attribute export and if I look into the source it is indeed so that I can’t find a method called export which is somewhat odd.

Any ideas why I can’t find the export method and how can I fix this? I already run conda install -c fastai fastai several times but it seems to be the latest version.

Learner.export is not available in 1.0.34, try 1.0.40 (or later)

Thank you. I had to update pytorch and fastai together to get the newest version :slight_smile:

How do I update with conda? I have 1.0.38 and when I try conda update fastai it says I have the latest one.

This worked for me:
conda install -c pytorch -c fastai fastai pytorch

Hi there - I"m having the same problem with floydhub. I even installed the dev version of fast.ai and still no luck. anyone have any ideas how I can resolve. Stuck partway through lession 2 of course v3

I ran into this problem too. I’m using conda to install/upgrade my fastai environment on a windows 10 machine.

Executing: conda install -c fastai fastai=1.0.45 yielded the package constraints preventing the update from succeeding. In my case the “spacy” package was stuck at 2.0.16, but fastai 1.0.45 requires spacy>=2.0.18

Then ran: conda install -c conda-forge spacy=2.0.18, which succeeded,
then ran the fastai install again and it worked.

To confirm ran:
conda list spacy
conda list fastai
conda list

1 Like

This also worked for me. I’m wondering if there is any way to customize where your model gets exported, right now it is just self.path, but it would be good to accept a different path.


You can pass fname = Path(to_wherever_I_want) as an argument :wink:

1 Like