Kernel Busy to No Connection (Jupyter Notebook)


I have succesfully connected to the AWS Instance, however I couldn’t execute any code on the Jupyter Notebook.

Each time I attempt to execute a line of code, the “Kernel Busy” symbol - what’s seen on the top right corner of the notebook. Sometimes the “Kernel Busy” turns to “No connection”.

Does anyone else have the same problem ? Any solutions recommended ?

Hi, dinesh!

How have you provisioned this instance? Have you used provided script or set up it manually?

Hello Alex,

Thanks very much for your reply.

I followed the below video “AWS Deep Learning setup” exactly as is:

Next, I also requested for the instance increase from 0 to 1 as described in the video (for which I got a confirmation email from Amazon after the service increase was completed) I only did the remaining steps after my instance increase was done.

The script that was used was the provided in Github.

It looks like you browser can’t establish WebSocket connection to the notebook.

Try to open notebook in Chrome and then View->Developer->JavaScript Console. Now select Kernel->Reconnect. What is the output in JS Console?

Typically you want to see something like this

1 Like

Hi Alex,

I performed the steps you provided and I have the below image with error on console:

One of the possible reasons is your provider blocking WebSocket connection. Can you check using different connection? For example, mobile or from different place.

Or you can ask your friend to check from his machine and see if error persists.

It maybe a server side problem but as far as I understand you can access you server using 8888 port when opening notebook initially. That means that security group on AWS and firewall rules on instance are correct.

Hi Alex,

I tried using my mobile phone connection and I observed the below error:

I suspect that this could actually be something to do with an extra installation on Cygwin, that I may need to do.
Please let me know if any solution is possible for this issue…

Hi all,

Did anyone have this exact same issue and was there any resolutions possible ? I have tried running multiple
commands from attempting to install and upgrading to new ipywidgets, but to no avail.

I’m excited to get started with the first Lesson on Deep Learning and I hope I can get this issue resolved :slight_smile:

Please kindly help…

Actually I have no ideas how to fix this issue - my knowledge of Java Script is pretty limited.

You can run the notebook with --debug flag just to see if it says something useful.

 jupyter notebook --debug

Yep, I’ve tried the above debug command and I get these:

It still gives the same error.

Did anyone else come across a similar error and how did you resolve it ?
Any pointers would be super helpful


I haven’t seen it before and it didn’t come up during the original course. Hope you can figure it out so we can document the solution in case it comes up again!

Does the message - Waiting for kernel to be available point out to the fact that Notebook isn’t connected to a kernel ?

Also, am I on the correct versions ?

Your versions look fine.

What happens if you create a brand new notebook from scratch and run something simple (eg “1+1”) in it?

Hi Jeremy,

I’ve created brand new Notebooks (just to refresh the Kernel), but still the same result.
I’ve so far tried various ways, so far nothing is working yet. This includes refreshing my browser cache as well
as attempting to run it on a fresh un-used browser - Firefox.

If I attempt to run Jupyter Notebook from my Anaconda Prompt, that works without a hitch.
It’s only happening with Cygwin64 & running it from Amazon EC2 instance.

Plus, the only similar errors I observe are the ones I’ve posted here.

Could I be missing something that should be installed in Cygwin64 OR Ubuntu server on AWS ?
(a dependency which is required by Jupyter Notebook to function normally) ?

The above shows the Conda environments that I installed to attempt if anything can be made to run on the Notebook - so far it’s not working either. Both the (conda env:py27 & conda env:py36) was tested and it resulted in the same “Kernel Busy” state.

I’m still thinking as to what else, I have yet to do to make this work…

Can you explain how do you do this?

The common workflow is to run jupyter notebook from EC2 instance using ssh connection and then go http://public_ip:8888 using your browser. No Cygwin involved.

Hi Alex,

I followed the steps provided on this video:

Hence, the SSH connection is connected through Cygwin to the EC2 instance, and then the website
http://public_ip:8888 is accessed via Chrome. This is because the video explained the necessity of having a bash terminal on Windows. Otherwise, I would have used Anaconda prompt.


  1. Start the Instance EC2 on Amazon’s EC2 Dashboard

  2. Launch Cygwin and execute the SSH command (that I got from the initial
    AWS Configuration phase on Cygwin)

  3. Type “Jupyter Notebook” on Cygwin

  4. Type in the webpage access link on Chrome (that I got from the initial
    AWS Configuration phase on Cygwin)

Also, the initial AWS Configuration step involved the usage of script that was provided with the course.

ok, I see. Can you show me the output of jupyter notebook --debug when you try to calculate smth in the notebook? Not from Java Script console but the output from the terminal you run this command in.

Hi Alex,

Below is the output on Cygwin Terminal as I tried doing a simple arithmetic on Jupyter.

Please see the bottom part of the output - there’s a line which indicates that websocket connection is being

Last login: Fri Jan 6 04:53:03 2017 from
ubuntu@ip-10-0-0-5:~$ jupyter notebook --debug
[D 09:48:59.357 NotebookApp] Searching [u’/home/ubuntu’, ‘/home/ubuntu/.jupyter’ , ‘/home/ubuntu/anaconda2/etc/jupyter’, ‘/usr/local/etc/jupyter’, ‘/etc/jupyter’ ] for config files
[D 09:48:59.358 NotebookApp] Looking for jupyter_config in /etc/jupyter
[D 09:48:59.358 NotebookApp] Looking for jupyter_config in /usr/local/etc/jupyte r
[D 09:48:59.359 NotebookApp] Looking for jupyter_config in /home/ubuntu/anaconda 2/etc/jupyter
[D 09:48:59.360 NotebookApp] Looking for jupyter_config in /home/ubuntu/.jupyter
[D 09:48:59.360 NotebookApp] Looking for jupyter_config in /home/ubuntu
[D 09:48:59.361 NotebookApp] Looking for jupyter_notebook_config in /etc/jupyter
[D 09:48:59.361 NotebookApp] Looking for jupyter_notebook_config in /usr/local/e tc/jupyter
[D 09:48:59.361 NotebookApp] Looking for jupyter_notebook_config in /home/ubuntu /anaconda2/etc/jupyter
[D 09:48:59.362 NotebookApp] Loaded config file: /home/ubuntu/anaconda2/etc/jupy ter/jupyter_notebook_config.json
[D 09:48:59.362 NotebookApp] Looking for jupyter_notebook_config in /home/ubuntu /.jupyter
[D 09:48:59.363 NotebookApp] Loaded config file: /home/ubuntu/.jupyter/jupyter_n
[D 09:48:59.364 NotebookApp] Looking for jupyter_notebook_config in /home/ubuntu
[D 09:48:59.369 NotebookApp] [nb_conda_kernels] refreshing conda info
[D 09:49:00.188 NotebookApp] [nb_conda_kernels] refreshing conda kernelspecs
[I 09:49:00.192 NotebookApp] [nb_conda_kernels] enabled, 4 kernels found
[I 09:49:00.196 NotebookApp] Writing notebook server cookie secret to /run/user/ 1000/jupyter/notebook_cookie_secret
[W 09:49:00.604 NotebookApp] WARNING: The notebook server is listening on all IP addresses and not using encryption. This is not recommended.
[I 09:49:01.295 NotebookApp] [nb_anacondacloud] enabled
[I 09:49:01.300 NotebookApp] [nb_conda] enabled
[I 09:49:01.375 NotebookApp] ✓ nbpresent HTML export ENABLED
[W 09:49:01.375 NotebookApp] ✗ nbpresent PDF export DISABLED: No module named nb browserpdf.exporters.pdf
[I 09:49:01.378 NotebookApp] Serving notebooks from local directory: /home/ubunt u
[I 09:49:01.378 NotebookApp] 0 active kernels
[I 09:49:01.378 NotebookApp] The Jupyter Notebook is running at: http://[all ip addresses on your system]:8888/
[I 09:49:01.378 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).
[I 09:49:06.597 NotebookApp] 302 GET / ( 0.63ms
[I 09:49:06.870 NotebookApp] 302 GET /tree? ( 0.92ms
[D 09:49:07.144 NotebookApp] Using contents: services/contents
[D 09:49:07.169 NotebookApp] Path base/images/favicon.ico served from /home/ubun tu/anaconda2/lib/python2.7/site-packages/notebook/static/base/images/favicon.ico
[D 09:49:07.172 NotebookApp] Path components/jquery-ui/themes/smoothness/jquery- ui.min.css served from /home/ubuntu/anaconda2/lib/python2.7/site-packages/notebo ok/static/components/jquery-ui/themes/smoothness/jquery-ui.min.css
[D 09:49:07.174 NotebookApp] Path components/jquery-typeahead/dist/jquery.typeah ead.min.css served from /home/ubuntu/anaconda2/lib/python2.7/site-packages/noteb ook/static/components/jquery-typeahead/dist/jquery.typeahead.min.css
[D 09:49:07.175 NotebookApp] Path style/style.min.css served from /home/ubuntu/a naconda2/lib/python2.7/site-packages/notebook/static/style/style.min.css
[D 09:49:07.179 NotebookApp] Path auth/css/override.css served from /home/ubuntu /anaconda2/lib/python2.7/site-packages/notebook/static/auth/css/override.css
[D 09:49:07.180 NotebookApp] Path components/es6-promise/promise.min.js served f rom /home/ubuntu/anaconda2/lib/python2.7/site-packages/notebook/static/component s/es6-promise/promise.min.js
[D 09:49:07.181 NotebookApp] Path components/requirejs/require.js served from /h ome/ubuntu/anaconda2/lib/python2.7/site-packages/notebook/static/components/requ irejs/require.js
[D 09:49:07.183 NotebookApp] Path base/images/logo.png served from /home/ubuntu/ anaconda2/lib/python2.7/site-packages/notebook/static/base/images/logo.png
[D 09:49:07.184 NotebookApp] 200 GET /login?next=%2Ftree%3F ( 41.30ms
[D 09:49:07.471 NotebookApp] Path custom.css served from /home/ubuntu/anaconda2/ lib/python2.7/site-packages/notebook/static/custom/custom.css
[D 09:49:07.472 NotebookApp] 304 GET /custom/custom.css ( 1.76ms
[D 09:49:07.779 NotebookApp] Path auth/js/main.min.js served from /home/ubuntu/a naconda2/lib/python2.7/site-packages/notebook/static/auth/js/main.min.js
[D 09:49:07.781 NotebookApp] 200 GET /static/auth/js/main.min.js?v=2017010609490 0 ( 2.40ms
[I 09:49:09.958 NotebookApp] 302 POST /login?next=%2Ftree%3F ( 0.88ms
[D 09:49:10.235 NotebookApp] Using contents: services/contents
[D 09:49:10.247 NotebookApp] Path tree/js/main.min.js served from /home/ubuntu/a naconda2/lib/python2.7/site-packages/notebook/static/tree/js/main.min.js
[D 09:49:10.255 NotebookApp] 200 GET /tree? ( 21.20ms
[D 09:49:10.555 NotebookApp] 304 GET /custom/custom.css ( 0.68ms
[D 09:49:10.932 NotebookApp] Path services/contents.js served from /home/ubuntu/ anaconda2/lib/python2.7/site-packages/notebook/static/services/contents.js
[D 09:49:10.934 NotebookApp] 200 GET /static/services/contents.js?v=201701060949 00 ( 2.83ms
[D 09:49:10.980 NotebookApp] Path custom.js served from /home/ubuntu/anaconda2/l ib/python2.7/site-packages/notebook/static/custom/custom.js
[D 09:49:10.981 NotebookApp] 200 GET /custom/custom.js?v=20170106094900 (60.54.4 .93) 1.61ms
[D 09:49:11.273 NotebookApp] 200 GET /api/config/tree?=1483696159036 ( 3) 3.88ms
[D 09:49:11.316 NotebookApp] 200 GET /api/config/common?
=1483696159037 (60.54.4 .93) 1.87ms
[D 09:49:11.504 NotebookApp] 200 GET /api/terminals?=1483696159038 ( 0.51ms
[D 09:49:11.551 NotebookApp] Native kernel (python2) available from /home/ubuntu /anaconda2/lib/python2.7/site-packages/ipykernel/resources
[D 09:49:11.553 NotebookApp] 304 GET /api/kernelspecs ( 6.76ms
[D 09:49:11.603 NotebookApp] 200 GET /api/sessions?
=1483696159039 ( 5.82ms
[D 09:49:11.643 NotebookApp] 200 GET /api/terminals?=1483696159040 ( 0.48ms
[D 09:49:11.692 NotebookApp] Path nb_conda/tree.js served from /home/ubuntu/anac onda2/share/jupyter/nbextensions/nb_conda/tree.js
[D 09:49:11.693 NotebookApp] 200 GET /nbextensions/nb_conda/tree.js?v=2017010609 4900 ( 4.40ms
[D 09:49:11.889 NotebookApp] 200 GET /api/contents?type=directory&
=148369615904 1 ( 3.44ms
[D 09:49:11.976 NotebookApp] Path nb_conda/models.js served from /home/ubuntu/an aconda2/share/jupyter/nbextensions/nb_conda/models.js
[D 09:49:11.978 NotebookApp] 200 GET /nbextensions/nb_conda/models.js?v=20170106 094900 ( 1.94ms
[D 09:49:12.027 NotebookApp] Path nb_conda/views.js served from /home/ubuntu/ana conda2/share/jupyter/nbextensions/nb_conda/views.js
[D 09:49:12.028 NotebookApp] 200 GET /nbextensions/nb_conda/views.js?v=201701060 94900 ( 1.83ms
[D 09:49:12.072 NotebookApp] Path nb_conda/urls.js served from /home/ubuntu/anac onda2/share/jupyter/nbextensions/nb_conda/urls.js
[D 09:49:12.073 NotebookApp] 200 GET /nbextensions/nb_conda/urls.js?v=2017010609 4900 ( 1.66ms
[D 09:49:12.260 NotebookApp] Path nb_conda/common.js served from /home/ubuntu/an aconda2/share/jupyter/nbextensions/nb_conda/common.js
[D 09:49:12.261 NotebookApp] 200 GET /nbextensions/nb_conda/common.js?v=20170106 094900 ( 1.76ms
[D 09:49:12.548 NotebookApp] Path nb_conda/conda.css served from /home/ubuntu/an aconda2/share/jupyter/nbextensions/nb_conda/conda.css
[D 09:49:12.549 NotebookApp] 304 GET /nbextensions/nb_conda/conda.css ( 3) 0.73ms
[D 09:49:12.596 NotebookApp] Path nb_conda/tab.html served from /home/ubuntu/ana conda2/share/jupyter/nbextensions/nb_conda/tab.html
[D 09:49:12.597 NotebookApp] 304 GET /nbextensions/nb_conda/tab.html ( ) 0.72ms
[D 09:49:13.779 NotebookApp] Using contents: services/contents
[D 09:49:13.780 NotebookApp] 200 GET /tree/nbs ( 1.68ms
[D 09:49:14.092 NotebookApp] 304 GET /custom/custom.css ( 0.69ms
[D 09:49:14.443 NotebookApp] 304 GET /custom/custom.js?v=20170106094900 (60.54.4 .93) 0.76ms
[D 09:49:14.730 NotebookApp] 200 GET /api/config/tree?=1483696162566 ( 3) 2.28ms
[D 09:49:14.775 NotebookApp] 200 GET /api/config/common?
=1483696162567 (60.54.4 .93) 1.82ms
[D 09:49:14.823 NotebookApp] 200 GET /api/terminals?=1483696162568 ( 0.51ms
[D 09:49:14.870 NotebookApp] Native kernel (python2) available from /home/ubuntu /anaconda2/lib/python2.7/site-packages/ipykernel/resources
[D 09:49:14.871 NotebookApp] 304 GET /api/kernelspecs ( 1.18ms
[D 09:49:14.921 NotebookApp] 200 GET /api/sessions?
=1483696162569 ( 0.58ms
[D 09:49:14.968 NotebookApp] 200 GET /api/terminals?=1483696162570 ( 0.49ms
[D 09:49:15.021 NotebookApp] 304 GET /nbextensions/nb_conda/tree.js?v=2017010609 4900 ( 0.59ms
[D 09:49:15.247 NotebookApp] 200 GET /api/contents/nbs?type=directory&
=14836961 62571 ( 1.71ms
[D 09:49:15.302 NotebookApp] 304 GET /nbextensions/nb_conda/models.js?v=20170106 094900 ( 0.60ms
[D 09:49:15.348 NotebookApp] 304 GET /nbextensions/nb_conda/views.js?v=201701060 94900 ( 0.55ms
[D 09:49:15.397 NotebookApp] 304 GET /nbextensions/nb_conda/urls.js?v=2017010609 4900 ( 0.55ms
[D 09:49:15.582 NotebookApp] 304 GET /nbextensions/nb_conda/common.js?v=20170106 094900 ( 0.78ms
[D 09:49:15.871 NotebookApp] 304 GET /nbextensions/nb_conda/conda.css ( 3) 0.71ms
[D 09:49:15.917 NotebookApp] 304 GET /nbextensions/nb_conda/tab.html ( ) 0.50ms
[I 09:49:19.496 NotebookApp] Creating new notebook in /nbs
[D 09:49:19.499 NotebookApp] Saving /home/ubuntu/nbs/Untitled.ipynb
[D 09:49:19.510 NotebookApp] 201 POST /api/contents/nbs ( 14.70ms
[D 09:49:19.794 NotebookApp] Using contents: services/contents
[D 09:49:19.820 NotebookApp] Path components/bootstrap-tour/build/css/bootstrap- tour.min.css served from /home/ubuntu/anaconda2/lib/python2.7/site-packages/note book/static/components/bootstrap-tour/build/css/bootstrap-tour.min.css
[D 09:49:19.822 NotebookApp] Path components/codemirror/lib/codemirror.css serve d from /home/ubuntu/anaconda2/lib/python2.7/site-packages/notebook/static/compon ents/codemirror/lib/codemirror.css
[D 09:49:19.823 NotebookApp] Path notebook/css/override.css served from /home/ub untu/anaconda2/lib/python2.7/site-packages/notebook/static/notebook/css/override .css
[D 09:49:19.825 NotebookApp] Path components/text-encoding/lib/encoding.js serve d from /home/ubuntu/anaconda2/lib/python2.7/site-packages/notebook/static/compon ents/text-encoding/lib/encoding.js
[D 09:49:19.827 NotebookApp] Path notebook/js/main.min.js served from /home/ubun tu/anaconda2/lib/python2.7/site-packages/notebook/static/notebook/js/main.min.js
[D 09:49:19.848 NotebookApp] 200 GET /notebooks/nbs/Untitled.ipynb?kernel_name=c onda-root-py ( 54.43ms
[D 09:49:20.144 NotebookApp] Path components/MathJax/MathJax.js served from /hom e/ubuntu/anaconda2/lib/python2.7/site-packages/notebook/static/components/MathJa x/MathJax.js
[D 09:49:20.144 NotebookApp] 304 GET /static/components/MathJax/MathJax.js?confi g=TeX-AMS_HTML-full,Safe&delayStartupUntil=configured ( 1.56ms
[D 09:49:20.188 NotebookApp] 304 GET /custom/custom.css ( 0.73ms
[D 09:49:20.477 NotebookApp] Path components/MathJax/config/TeX-AMS_HTML-full.js served from /home/ubuntu/anaconda2/lib/python2.7/site-packages/notebook/static/ components/MathJax/config/TeX-AMS_HTML-full.js
[D 09:49:20.477 NotebookApp] 304 GET /static/components/MathJax/config/TeX-AMS_H TML-full.js?rev=2.6.0 ( 1.49ms
[D 09:49:20.566 NotebookApp] 304 GET /custom/custom.js?v=20170106094900 (60.54.4 .93) 0.56ms
[D 09:49:20.786 NotebookApp] Path components/MathJax/config/Safe.js served from /home/ubuntu/anaconda2/lib/python2.7/site-packages/notebook/static/components/Ma thJax/config/Safe.js
[D 09:49:20.786 NotebookApp] 304 GET /static/components/MathJax/config/Safe.js?r ev=2.6.0 ( 0.69ms
[D 09:49:20.853 NotebookApp] 200 GET /api/config/notebook?=1483696168662 (60.54 .4.93) 2.59ms
[D 09:49:20.899 NotebookApp] 200 GET /api/config/common?
=1483696168663 (60.54.4 .93) 1.81ms
[D 09:49:20.950 NotebookApp] Native kernel (python2) available from /home/ubuntu /anaconda2/lib/python2.7/site-packages/ipykernel/resources
[D 09:49:20.951 NotebookApp] 304 GET /api/kernelspecs ( 1.16ms
[D 09:49:21.000 NotebookApp] 200 GET /api/contents/nbs/Untitled.ipynb?type=noteb ook&=1483696168664 ( 4.78ms
[D 09:49:21.088 NotebookApp] Path components/MathJax/jax/output/HTML-CSS/fonts/S TIX-Web/fontdata.js served from /home/ubuntu/anaconda2/lib/python2.7/site-packag es/notebook/static/components/MathJax/jax/output/HTML-CSS/fonts/STIX-Web/fontdat a.js
[D 09:49:21.089 NotebookApp] 304 GET /static/components/MathJax/jax/output/HTML- CSS/fonts/STIX-Web/fontdata.js?rev=2.6.0 ( 3.13ms
[D 09:49:21.130 NotebookApp] Path components/MathJax/extensions/Safe.js served f rom /home/ubuntu/anaconda2/lib/python2.7/site-packages/notebook/static/component s/MathJax/extensions/Safe.js
[D 09:49:21.131 NotebookApp] 304 GET /static/components/MathJax/extensions/Safe. js?rev=2.6.0 ( 1.18ms
[D 09:49:21.177 NotebookApp] Path nb_anacondacloud/main.js served from /home/ubu ntu/anaconda2/share/jupyter/nbextensions/nb_anacondacloud/main.js
[D 09:49:21.179 NotebookApp] 200 GET /nbextensions/nb_anacondacloud/main.js?v=20 170106094900 ( 2.08ms
[D 09:49:21.222 NotebookApp] Path nb_conda/main.js served from /home/ubuntu/anac onda2/share/jupyter/nbextensions/nb_conda/main.js
[D 09:49:21.223 NotebookApp] 200 GET /nbextensions/nb_conda/main.js?v=2017010609 4900 ( 1.37ms
[D 09:49:21.269 NotebookApp] Path jupyter-js-widgets/extension.js served from /h ome/ubuntu/anaconda2/share/jupyter/nbextensions/jupyter-js-widgets/extension.js
[D 09:49:21.314 NotebookApp] Path nbpresent/js/nbpresent.min.js served from /hom e/ubuntu/anaconda2/share/jupyter/nbextensions/nbpresent/js/nbpresent.min.js
[D 09:49:21.315 NotebookApp] 200 GET /nbextensions/nbpresent/js/nbpresent.min.js ?v=20170106094900 ( 2.61ms
[D 09:49:21.373 NotebookApp] Starting kernel: [u’/home/ubuntu/anaconda2/bin/pyth on’, ‘-m’, ‘ipykernel’, ‘-f’, u’/run/user/1000/jupyter/kernel-5a2924ca-488c-4e04 -ac7a-b086d762153d.json’]
[D 09:49:21.380 NotebookApp] Connecting to: tcp://
[I 09:49:21.381 NotebookApp] Kernel started: 5a2924ca-488c-4e04-ac7a-b086d762153 d
[D 09:49:21.381 NotebookApp] Kernel args: {‘kernel_name’: u’conda-root-py’, ‘cwd ‘: u’/home/ubuntu/nbs’}
[D 09:49:21.382 NotebookApp] 201 POST /api/sessions ( 24.50ms
[D 09:49:21.404 NotebookApp] 200 GET /api/contents/nbs/Untitled.ipynb/checkpoint s?
=1483696168665 ( 1.11ms
[D 09:49:21.508 NotebookApp] 304 GET /nbextensions/nb_conda/models.js?v=20170106 094900 ( 0.86ms
[D 09:49:21.620 NotebookApp] 304 GET /nbextensions/nb_conda/views.js?v=201701060 94900 ( 0.69ms
[D 09:49:21.667 NotebookApp] Path nbpresent/css/nbpresent.min.css served from /h ome/ubuntu/anaconda2/share/jupyter/nbextensions/nbpresent/css/nbpresent.min.css
[D 09:49:21.667 NotebookApp] 304 GET /nbextensions/nbpresent/css/nbpresent.min.c ss ( 2.53ms
[D 09:49:21.710 NotebookApp] 304 GET /nbextensions/nb_conda/urls.js?v=2017010609 4900 ( 0.56ms
[D 09:49:21.758 NotebookApp] Path nbpresent/js/nbpresent.deps.min.js served from /home/ubuntu/anaconda2/share/jupyter/nbextensions/nbpresent/js/nbpresent.deps.m in.js
[D 09:49:21.812 NotebookApp] 304 GET /nbextensions/nb_conda/common.js?v=20170106 094900 ( 0.61ms
[D 09:49:21.891 NotebookApp] Initializing websocket connection /api/kernels/5a29 24ca-488c-4e04-ac7a-b086d762153d/channels
[D 09:49:21.893 NotebookApp] Requesting kernel info from 5a2924ca-488c-4e04-ac7a -b086d762153d
[D 09:49:21.893 NotebookApp] Connecting to: tcp://
[D 09:49:21.938 NotebookApp] Received kernel info: {u’status’: u’ok’, u’language info’: {u’mimetype’: u’text/x-python’, u’nbconvert_exporter’: u’python’, u’name ‘: u’python’, u’pygments_lexer’: u’ipython2’, u’version’: u’2.7.13’, u’file_exte nsion’: u’.py’, u’codemirror_mode’: {u’version’: 2, u’name’: u’ipython’}}, u’imp lementation’: u’ipython’, u’implementation_version’: u’5.1.0’, u’protocol_versio n’: u’5.0’, u’banner’: u’Python 2.7.13 |Anaconda custom (64-bit)| (default, Dec 20 2016, 23:09:15) \nType “copyright”, “credits” or “license” for more informati on.\n\nIPython 5.1.0 – An enhanced Interactive Python.\n? -> Introducti on and overview of IPython’s features.\n%quickref -> Quick reference.\nhelp -> Python’s own help system.\nobject? -> Details about ‘object’, use ‘ob ject??’ for extra details.\n’, u’help_links’: [{u’url’: u’http://docs.python.or g/2.7’, u’text’: u’Python’}, {u’url’: u’’, u’text’: u’IPython’}, {u’url’: u’’, u’ text’: u’NumPy’}, {u’url’: u’’, u’text ‘: u’SciPy’}, {u’url’: u’’, u’text’: u’Matplo tlib’}, {u’url’: u’’, u’text’: u’SymPy’}, {u’url’: u’’, u’text’: u’pandas’}]}
[D 09:49:21.939 NotebookApp] Opening websocket /api/kernels/5a2924ca-488c-4e04-a c7a-b086d762153d/channels
[D 09:49:21.939 NotebookApp] Connecting to: tcp://
[D 09:49:21.939 NotebookApp] Connecting to: tcp://
[D 09:49:21.939 NotebookApp] Connecting to: tcp://
[D 09:49:22.096 NotebookApp] 304 GET /nbextensions/nb_conda/conda.css ( 3) 0.62ms
[D 09:49:22.140 NotebookApp] Path nb_conda/menu.html served from /home/ubuntu/an aconda2/share/jupyter/nbextensions/nb_conda/menu.html
[D 09:49:22.141 NotebookApp] 304 GET /nbextensions/nb_conda/menu.html ( 3) 0.70ms
[D 09:49:22.202 NotebookApp] 200 GET /nbextensions/nbpresent/js/nbpresent.deps.m in.js?v=20170106094900&v=20170106094900 ( 444.88ms
[D 09:49:22.401 NotebookApp] 200 GET /nbextensions/jupyter-js-widgets/extension. js?v=20170106094900 ( 1132.75ms
[D 09:49:24.591 NotebookApp] Path nbpresent/js/nbpresent.notebook.min.js served from /home/ubuntu/anaconda2/share/jupyter/nbextensions/nbpresent/js/ tebook.min.js
[D 09:49:24.594 NotebookApp] 200 GET /nbextensions/nbpresent/js/nbpresent.notebo ok.min.js?v=20170106094900&v=20170106094900 ( 3.61ms
[D 09:49:26.429 NotebookApp] 304 GET /api/nbconvert ( 0.88ms
[W 09:50:51.939 NotebookApp] WebSocket ping timeout after 90000 ms.
[D 09:50:55.509 NotebookApp] Initializing websocket connection /api/kernels/5a2924ca-488c-4e 04-ac7a-b086d762153d/channels
[W 09:50:55.511 NotebookApp] Replacing stale connection: 5a2924ca-488c-4e04-ac7a-b086d762153 d:DEBC50DA5BB441CB85101CB41499F0E1
[D 09:50:56.941 NotebookApp] Websocket closed 5a2924ca-488c-4e04-ac7a-b086d762153d:DEBC50DA5 BB441CB85101CB41499F0E1
[D 09:50:56.942 NotebookApp] Opening websocket /api/kernels/5a2924ca-488c-4e04-ac7a-b086d762 153d/channels
[D 09:50:56.942 NotebookApp] Connecting to: tcp://
[D 09:50:56.942 NotebookApp] Connecting to: tcp://
[D 09:50:56.943 NotebookApp] Connecting to: tcp://
[D 09:51:21.371 NotebookApp] 200 GET /api/contents/nbs/Untitled.ipynb?content=0&
=1483696168666 ( 1.08ms
[I 09:51:21.892 NotebookApp] Saving file at /nbs/Untitled.ipynb
[D 09:51:21.892 NotebookApp] Saving /home/ubuntu/nbs/Untitled.ipynb
[D 09:51:21.907 NotebookApp] 200 PUT /api/contents/nbs/Untitled.ipynb ( 267.53ms
^C[I 09:51:53.393 NotebookApp] interrupted
Serving notebooks from local directory: /home/ubuntu
1 active kernels
The Jupyter Notebook is running at: http://[all ip addresses on your system]:8888/

This is the problem. However, quick googling found no solution.

Possibly, this will help: