Kernal Restarting without error when using ImageClassifierData.from_csv?

Hey guys,

I have been trying to predict labels for images on Yelp DataSet on Kaggle.

I basically tried to refer to the steps of multi-label classification like the satellite images as possible but my kernel keeps restarting whenever I call this function

def get_data(sz):
    tfms = tfms_from_model(arch, sz ,aug_tfms=transforms_top_down, max_zoom=1.05, )
    return ImageClassifierData.from_csv(path, 'train_photos', label_csv, tfms=tfms, suffix='.jpg', val_idxs=val_idxs)    

To explain in detail on what I did:-

  1. I created a data frame with the photo Ids and the labels and saved it as a CSV file as shown below.

this CSV file has around 234842 images so technically those many rows.

  1. Now I created the get_data function using the function above as mentioned. But when I run the function using even an sz = 64 and bs = 4 the kernel starts restarting.

There is no error whatsoever on the terminal.

I tried increasing the iopub data rate limit using
Jupiter notebook -- NotebookApp.iopub_data_rate_limit=10000000000

but it doesn’t work. I also tried restarting the kernel and the GPU but I can seem to overcome this problem. Can someone pls explain why this is happening and how I can overcome this? I also tried this fix. None of them are working.

Thanks a lot in advance.

@jeremy @farhanhubble @wnurmi @j.laute

Can you see a more detailed error message and exact place in code inside fastai where it is happening? Which version of fastai are you one?

I am unable to see a more detailed error message. That is all the error I get. Is there some way I can get it to show more detailed logs?


I am using the latest version of Fastai. I just pulled the recent git repo and tried again but it still keeps restarting.

The exact place that gives me this error is when I call the get_data(64) function using this line
data = get_data(64)

How was it installed, and which version of the satellite image notebook are you using then? As far as I’ve understood, the latest version of fastai doesn’t work with the old course notebooks… Did you follow the install instructions in the readme?

I installed it following the instructions on the course so from the readme, I am guessing the version is 0.7.x. No, I followed the instructions by reshamas (given on the course lesson 1 page) so it’s not the latest version(1.x) and it has been working for all the examples in the course. Only in this case the kernal is restarting.