!jupyter serverextension enable voila —sys-prefix

Hi there,

Right now I am working with 02_production.ipynb to create my app using binder. but when I run the code to installa voila I get this error:

Error loading server extension —sys-prefix
X is —sys-prefix importable?

Any advice?


Hi @ricardocalleja - I ran into the same issue, I fixed it by replacing —sys-prefix with --sys-prefix which is what https://github.com/voila-dashboards/voila suggests it should be. Hope this helps.


Thanks @Hrowalters Now it works!


Hi @ricardocalleja @hrowalters, I’ve tried this, but it still has not solved the issue for me. Is there any other steps I need to take to solve this issue?

I’ve seen some fixes for Colab to get widgets working, but this doesn’t seem to be the same issue.


Hi @echeng - I think it might be because you’re using Colab. I was using Gradient (and I’m assuming Ricardo might have been too).

According to the replies to this post, Voila may not work with Colab :confused: I tried to get Colab to work and was also having issues.

I’d suggest you download (the shortened version of) your notebook & .pkl file, launch a CPU instance in Gradient and try again over there.


Hi, @echeng, This is the repo I used in github to create the web app, maybe you could check it to see if you find any discrepancies that might be generating the error that you have.


@ricardocalleja thanks very much for sharing that repo! It was super helpful. I have compared my repo with yours, and besides the README and LICENSE, our repos are the same, but I still can’t get it work. I will have to circle back to this problem later. Thanks again!

1 Like

@echeng This is how I edited(raw) my README file:

I remember that first it didn’t work for me because I had forgotten to include de URL of mybinder

You could also use the same LICENSE, just in case. Who knows, I am just guessing and trying to help.

1 Like

Where you able to make it work?

Hey @ricardocalleja, sorry for the late reply. I’ve had to take a break from fast.ai for a few days, but I’m hoping to circle back to it this weekend. I will post an update hopefully once I get it working. Thanks for checking in!

Hi @ricardocalleja, just wanted to let you know that everything is working now! Very beginner oversight, but I didn’t realize that the requirements.txt was necessary to help Binder build the proper environment to run the app. Thanks for your help.

1 Like

Nice, if you can, please share your repo, because mine is not working lately…

@ricardocalleja here it is:

1 Like

Hello @ricardocalleja , I am going through the same error with google collab. Should I use gradient instead ?

Hi @tanupunjani I ended up using SeeMe.ai (SeeMe.ai Deployment. | Practical Deep Learning for Coders) I was not able to deploy it using Binder. Sorry for not being of much help

1 Like

Thank you so much for replying me. I am very junior in learning fast ai. I am trying to deploy the first ML project. - dog breed identification through binder. Should I spend my time on this right now or move on to learning building models ?

Thanks again,

I am also an entry level practitioner. So, deploying is cool, because you can share with you friends, but honestly if you already trained the model and it worked fine you already did 95% of the work!. Keep moving forward with the course.

1 Like

Thank you for the advise. Do you use SeeMe ai for even google collab ?

When I started I used Gradient, but now I believe Collab is better

1 Like

Thank you for sharing See Me AI link. My project is successfully deployed.

Tanvi :grinning: