Jupyter problem

Hi. I followed :
B) Now, move into a directory where you are comfortable installing the Fastai repo, with its libraries and required packages.
Now you got to clone that repo as follows:

> git clone https://github.com/fastai/fastai

C) Once the cloning process finishes, be sure to be in the directory created by git for the Fastai repository, and type:

conda env create -f environment-win.yml`

followed by:

activate fastai`

This will install the required packages and their dependencies into the fastai environment by leveraging the file environment-win.yml prepared by Fast.ai .

D) Now, open jupyter:

(fastai)> jupyter notebook

but when i type ‘jupyter notebook’ I got:
“(fastai) C:\Users\User\fastai>jupyter notebook
‘jupyter’ is not recognized as an internal or external command,
operable program or batch file.”

Do You know a solution of that problem? :slight_smile:

In case you haven’t seen the other posts - there is an issue with the Jupyter packages so they were commented out in the environment file - and then these and a few others need to be added manually - see this thread which has some good steps for the missing stuff.

Yes I do…

If the jupyter installed by pip or conda , and after you activate the environment, if it not find it to execute then its because the path where its installed wasn’t recognized.

I really don’t know what repository are you using that has a environment-win.yml on it.

So will be very difficult to understand the steps you made that lead to this situation.

I didnt have this file so i changed it to environment.yml.
https://github.com/fastai/fastai It is the repository .

Ok I get that, but this don’t tell me nothing about the steps you made that may have caused this problem. Also your information about your process to install is limited.

So I only can suggest you to remove everything and start again following the steps on the Git Repo or specify in details the steps you made so I can understand what happened to help you out.

All I did was following those steps.I took it from here How to set up Windows 10 for fast.ai

Ok to start helping you,I need you to give some extra informations:

  • What is the windows version:
  • what is the path where you cloned the repostirory:
  • Witch conda version are you using:
  • What is the path you installed anaconda or miniconda:
  • Witch fastai version (professor jeremy changed entire the repository 3 hours ago):
  • Are you administrator or a normal user account

Giving me that information I will simulate your problem here.

Windows 10
conda 4.5.11
I cloned repository 2 hours ago,so I guess it is the newest
Admin account

Hi again …sorry about the time to reply … I get late to see your message and install windows to test it, but I did and it worked. There wasn’t a reason to not to.
Sorry I couldn’t get the error you experiencing at all.

0- Installed Notepad++
1- Installed Windows 10 Pro (Express Install)
2- Installed Git 2.19-64 bits (Express Install) pointed editor to Notepad++ and to work only from GitBash
3- Installed Anaconda3 5.2.0 - 64 bit (Express Install) pointed installation to my user only(recommended) and also not put in the environment variable because wasnt recommended
4- Created a folder Projects on c:
5- Cloned the fastai repo inside of c:\Projects
6- Restarted the machine just to make sure
7- Opened Anaconda Prompt and Navigated to the Fastai folder in (base) C:\Projects\fastai
8- inside the fastai folder and with the base environment active I executed :
(base) conda env update
9- After instalation I entered environment by :
(base) conda activate fastai → (fastai) c:\Projects\fastai
10- I executed the following command to see if the packages was there:
(fastai) conda list
11- then I called jupyter by :
(fastai) jupyter notebook

1- At the end of instalation of fastai packages I got the following message error, but I decided to attack after jupyter testing :slight_smile:

distutils.errors.DistutilsError: Download error for https://files.pythonhosted.org/packages/69/1c/98cba002ed975a91a0294863d9c774cc0ebe38e05bbb65e83314550b1677/pbr-4.2.0-py2.py3-none-any.whl#sha256=b486975c0cafb6beeb50ca0e17ba047647f229087bd74e37f4a7e2cac17d2caa:
[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:841)
…blablablabla …, and I don’t care :rofl:

2- I just tried to updated the pip package , but I got another error message:
(fastai) c:\Projects\fastai>pip install --upgrade pip

ERROR: To modify pip, please run the following command:
C:\Users\Willismar\Anaconda3\envs\fastai\python.exe -m pip install --upgrade pip
You are using pip version 10.0.1, however version 18.0 is available.
You should consider upgrading via the ‘python -m pip install --upgrade pip’ command.

3-Then I followed the instruction the system gave to me and it worked, but also generated a WARNING later.
(fastai) c:\Projects\fastai>C:\Users\Willismar\Anaconda3\envs\fastai\python.exe -m pip install --upgrade pip

twisted 18.7.0 requires PyHamcrest>=1.9.0, which is not installed.
pexpect 4.6.0 requires ptyprocess>=0.5, which is not installed.
spacy 2.0.12 has requirement regex==2017.4.5, but you’ll have regex 2018.7.11 which is incompatible.
Installing collected packages: pip
Found existing installation: pip 10.0.1
Uninstalling pip-10.0.1:
Successfully uninstalled pip-10.0.1
Successfully installed pip-18.0

4- Next had to attack the tree remaining packages:

(fastai) c:\Projects\fastai>pip install PyHamcrest==1.9.0
(fastai) c:\Projects\fastai>pip install ptyprocess==0.5
(fastai) c:\Projects\fastai>pip install regex==2017.4.5

5- Everything was fine after. If I execute (fastai) conda env update , it not find anything left to be installed :slight_smile:


Hmm I need to check that again.I installed fastai on my 2nd laptop and I didnt have this problem.I will try tomorrow to follow Your steps :slight_smile: Huge thanks for Your help :slight_smile: