Jupyter Notebook Kernal Dies

I was doing the grocery competition in my local machine, not AWS.
First I tried the RF mentioned in class and followed the instruction exactly with all the tricks but the kernel died every time when I m.fit(x, y), even with the subset data.
Then I was trying to do the aggregate first to get the mean and join back to the test data. But again, even with 1m subset it died when I merged the mean and the test data…

This is being very frustrating. Please help!

I can merge super fast with multiple columns matching but got NaN as the result. But when I match only one column, ex. store_nbr, the kernal dies…

Update: Ahh the NaN is solved. I am matching too many columns. But still I failed to do RF.fit()

@tinapeng, unfortunately you haven’t provided enough information to allow people to help you. That’s OK though - it’s hard to know what information to provide, and takes practice! Here’s some tips to help you: http://wiki.fast.ai/index.php/How_to_ask_for_Help . Also, take a look at how other people on the forum have asked for help, and what approaches have been successful. Note that the successful ones tend to show screenshots, links to notebooks, full error messages, etc so that everyone can see what’s going on.


Thank you for the advice Jeremy. I will surely work on it!

I have met a similar error on AWS. It happens when I try to run two jupyter notebooks at the same time, which eats up all the memory. You can check your memory usage on your local machine. I solved this problem by simply restarting my jupyter notebook. Hope it helps.

1 Like