Jupyter kernel restarting when running Lesson 1


I have set up fastai-cpu version as I don’t have supported GPU. When I run lesson 1 in jupyter notebook after downloading model, the following code:

data = ImageClassifierData.from_paths(PATH, tfms=tfms_from_model(arch, sz))
learn = ConvLearner.pretrained(arch, data, precompute=True)
learn.fit(0.01, 2)

restarts jupyter kernel with The kernel appears to have died. It will restart automatically.

Have anyone faced similar issue?

My computer doesn’t have supported GPU as well, I just install the fastai environment from the yaml and now it works for me:


In addition, I recommend you to use paperspace or aws.
when you just play around and didn’t use code that uses the GPU run it on your pc and when you want to start fitting and use the GPU, move the notebook with scp to the instants and run it there, because it takes a lot of time to run this code on CPU.

Thank you suggestion, I’ve tried to use environment-cpu.yml and environment.yml but I have the same issue in both cases. I don’t wanna use paperspace or aws it is not free. I’m trying to use CPU, just to see how everything works.

And you activate it right?
like this:

source activate fastai

or in windows(I never test it):

activate fastai

Yes, I did. I’ve tried to run it on Windows and Mac. I’m getting the same error and I’ve tried from scratch also. I’ve tried to debug code and I’m pretty sure it inside Leaner throws this type error.