Jupyter kernel died everytime I run "show_batch"

hi everyone, when I am running the below code from 02_production.ipynb:

dls = bears.dataloaders(path)  # this line can execute normally

dls.valid.show_batch(max_n=4, nrows=1)  # this line make jupyter kernel died

my jupyter kernel always died. if any one have an idea what this issue is?

If you running locally it might be your system running out of memory.

Hi! I get the same when trying to load UNet keras model on remote Jupyter notebook. The system, I guess, was fine. What else could it be?

not really, when I run dls.valid.show_batch,the code haven’t train any mode yet, just build some data structure. probably some bug on jupyter, cause I try the same code in Pycharm,finish with code 0, seems nothing error happen in pycharm.

I meet the issue on local jupyter server, not only show_batch method, but also show results method will cause jupyter kernel crashed. It is really weird.

Seems to be having the same issue with data.show_batch() when I run it locally. But does work on google vertex ai workbench.