Jupyter can't connect to kernel

Jupyter can’t connect to kernel when I use proxy network of my college.

Since my college doesn’t allow connections through port 22 hence I made a successful ssh connection using port 443(allowed by college).I ran a jupyter notebook in GCP then tried to open it in my browser.I can see all the contents and open the notebooks but after that it is struck on connecting to kernel.

Also as far as I know jupyter notebooks don’t require a ssh connection.
Do I need to make some changes to jupyter configuration file ?

I am facing similar problem.
It has something to do with my (and your) College’s Firewall not allowing websocket connection between the jupyter notebook and web browser.
Initially, mine wouldn’t even load the page on college’s network, turns our, my college’s firewall doesn’t allow port 8888 for some reason. Changed the port to 8080 from Jupyter Notebook Config, and the page now loads but can’t connect to the kernel.
Have been using the Mobile Phone’s internet for now,

ps, I also tried using a vpn. Doesn’t work. I read somewhere that the vpn might be changing the protocol from websocket to http.

Any Help from anyone out there is welcome.

Check this post:

Basically let jupyter traffic go through ssh. And I guess this is also more secure way.