Issue with running Intro on Colab

Refresh the page

I was having the same issue, and the solution is to refresh your page. It’s just a colab issue with their authorization. If you don’t get the authorization prompt, then refresh and try again. Here’s what you should see when it does work correctly.

1 Like

I am facing the same issue. Any help would be appreciated

I found copying the notebook into my drive solved the problem. I think the underlying problem was some issue with caching. A way I suspect you can anticipate whether it will work or not is whether your browser icon is golden - the notebook running/active - or gray. My hunch is you want it to be gray.

If this doesn’t work, too, try to copy it into your drive. If this keeps occurring, I wonder if a better way to open these notebooks would be in incognito - but that might not make sense.

Zachary, if you’re looking for more here, check my replies below. tl;dr I think it’s an auth caching issue problem. I wonder if a test you could do for this to be reproducible is if you don’t have any issues in incognito

I didn’t (I was in incognito). Do note that you have to sign into Google in some degree before it’ll let you run anything.

I cloned the course-v4 repository into my drive and opened the notebook from there. By copying do you mean doing it a different way to the one I have mentioned?

I’m still running into this problem using GPU on Google Colab.
Can someone help out please?
Refreshing the page isnt helping.

For folks still getting issues, could you answer a few questions for me so i can try to recreate this?

  1. Have you opened a notebook in Colab before, or is it completely new for the account
  2. How are we opening the Notebook? Are you opening it from the URL in fastbook? Are you opening it from GitHub inside Colab? do you have the notebook downloaded inside of your Google drive?
  3. What browser are you opening it in? If in chrome, are you in incognito mode?

I was running my previous Colab notebook in the Google Chrome browser and running into errors.
Using Mozilla Firefox, the code worked just fine.

Try using a different browser if you face the same issue.

Along with that perhaps clearing the cache

1). I had opened notebooks prior to this with the account.
2). I was opening it from previously searched and hence saved Google Colab URL.
3). Chrome, regular mode.

1 Like

Did it originate from the GitHub? The Colab URLs linked in the Colab setup? (Sorry just a little confused by the answer :slight_smile: )

I used this URL .

Also, maybe try posting a comment with all solutions that have worked so far as it will make it easy for people to solve this problem.

What does !pip show fastai give? Also did we attempt to restart the runtime and then import fastai? Also, which notebook were we trying to run?

What I did to resolve the error message is I saved the Colab file on my Google Drive. I then closed all Colab sessions and reopen the saved file from the drive.

Hope this helps someone.

I too got the same issue as you guys. Initially it was not working properly on CPU or GPU. This thread is really helpful but i believe the answers are too scattered so I will write all the points that actually worked for me.

  1. !pip install pandas==1.1.0 as there is some version issue in colab. This might help to run the notebook using a CPU.
  2. Change runtime to GPU and run the same cells and you’ll get the above error. I did not do anything much . Just restart your runtime and re run the cells. Hopefully there wont be any errors now:)

Having same problem, on Firefox. I’ve used Colab with PyTorch before without any problems.

For me, copying the notebook to my Drive and running the copy got me through the import error and I managed to auth as well. But now I’m getting a TIMEOUT error:

The Drive isn’t full or anything, I also authenticated and gave it permissions, so it shouldn’t be a problem with Drive.

I’ve been running into issues like this on Colab today. Last week it was running fine on Colab. I just gave up and started running on Paperspace Gradient free tier with no issues.

Last week colab was running fine. But today I am getting the pandas incompatibility error during install.
ERROR: fastai 2.0.8 has requirement pandas>=1.1.0, but you’ll have pandas 1.0.5 which is incompatible.