InstanceLimitExceeded (but shouldn’t be)

I followed the instructions and requested an increase of p2.xlarge to 1 instance. I got confirmation that it was approved.

If I go to: EC2 Service Limits, I find:
This page lists your EC2 service limits in US West (Oregon).
Running On-Demand p2.xlarge instances 1 Request limit increase

I check my config file for region:
$ cat ~/.aws/config
[default]
output = text
region = us-west-2

When I run setup_p2.sh I get the following:

True

An error occurred (InstanceLimitExceeded) when calling the RunInstances operation: You have requested more instances (1) than your current instance limit of 0 allows for the specified instance type. Please visit http://aws.amazon.com/contact-us/ec2-request to request an adjustment to this limit.

Any idea what could be wrong?

Thank you very much, Ben

It looks you are doing everything correctly (it looks exactly like what I did). You’ll need to ping AWS support you haven’t done so already.

I get this error when I try to launch another instance (aws ec2 start-instances) when 1 is already running. You may want to see https://aws.amazon.com/console/ and make sure there are no running instances (and you are not being billed!).

Check if you got reply from support or service team. Amazon has two levels of request confirmation: first support, then actual increase by service team.

1 Like

So, on June, 9th I’ve reached them for ETAs and got an answer that they misinterpreted my request (they missed that I’m having issues with Sport Instances and requested increase for regular ones) and I’ve got my limit increase.

1 Like

Hi Gaiar

I have the same problem. Because of many problems with installing AWS,
I tried to create a new start by deleting the user, VPC’s, releasing elastic IP’s on the AWS-console.
Then I created a new user, and then I got your problem.

$ bash setup_p2.sh
True

An error occurred (InstanceLimitExceeded) when calling the RunInstances operation: You have requested more instances (1) than your current instance limit of 0 allows for the specified instance type. Please visit http://aws.amazon.com/contact-us/ec2-request to request an adjustment to this limit.

An error occurred (MissingParameter) when calling the CreateTags operation: The request must contain the parameter resourceIdSet
Waiting for instance start…

My questions are:

  • any suggestions?
  • does AWS charge for this kind of support?
  • could my problem have been caused by making a fresh start?
    Thanks,
    Pieter

Hello benal, I have the same problem, were you able to solve it? I’ve asked for support and they said then increased the g2.2xlarge limit to 1.

Also I find interesting that p2.xlarge != g2.2xlarge … but in the online course it said g2.2xlarge.

I had the same issue, checked my limits and p2.xlarge is set to 0. Going to request an increase to see if the error goes away when I execute the script.

Cheers,
Paul

This might be useful for somebody: the problem was that I requested a g2 instance and not a p2 instance. I requested a p2 instance an everything worked.

2 Likes

Thanks it worked for me.

I had the same issue and i search all over for a fix.

If you have approval and it is showing up on aws as 1 instance improved the fix is the following

In the file setup_p2.sh file you must change ( instanceType=“p2.xlarge” ) to (instanceType=“p2.8xlarge”). I changed any instance of p2.xlarge to p2.8xlarge. This worked for me.

to change this I just renamed setup_p2.sh to setup_p2.txt then opened the file in notepad and edited it and resaved it as setup_p2.sh.

I hope this works for you

.

1 Like