Installing Windows Subsystem for Linux (WSL)

I am trying to install Windows Subsystem for Linux (WSL).

For simplified installation, when I try to run “wsl --install” in the command window, I receive this message:

“The requested operation requires elevation.”

For manual installation, when I try to run “dism.exe /online /enable-feature /featurename:Microsoft-Windows-Subsystem-Linux /all /norestart”, I receive this message:

“Error: 740

Elevated permissions are required to run DISM.
Use an elevated command prompt to complete these tasks.”

Can someone assist me to resolve this problem?


Also as a follow-up, does anyone know how to kill the Vmmem process which is taking up nearly 30-40% memory and doing wsl --shutdown only reduces the memory consumption by half but doesn’t kill it.

I resolved the problem by right-clicking the Windows PowerShell & Command Prompt apps and clicking “Run as administrator”.

However, I now have a new problem; When I open the Linux distribution, it states the following:

“Installing, this may take a few minutes…
WslRegisterDistribution failed with error: 0x8007019e
The Windows Subsystem for Linux optional component is not enabled. Please enable it and try again.
See Install WSL on Windows 10 | Microsoft Docs for details.
Press any key to continue…”

Windows Subsystem for Linux is enabled in my notebook but I still get the message above.

The Linux distributions I installed & opened, and where I received this same message, are:
Ubuntu 18.04 LTS; and
Ubuntu 20.04 LTS.

Hi A-J
Elevated means when you type in ISE in the search bar you need to select the Run as Administrator.
Are you following Install WSL on Windows 10 | Microsoft Docs
Regards Conwyn

I managed to resolve my problem above and generated the public/private rsa key pair at Ubuntu 20.04 LTS.

Now, I have a new problem regarding importing a key pair in AWS: Exactly how do I find the key pair file ( in my notebook?

I managed to solve my problems up until launching an instance on AWS (Step 4 of AWS EC2 | Practical Deep Learning for Coders).

I get this message from AWS:
“Launch Failed
You have requested more vCPU capacity than your current vCPU limit of 2 allows for the instance bucket that the specified instance type belongs to. Please visit to request an adjustment to this limit.”

I requested & obtained approval for the adjustment to the limit but still get the error message above.

Can someone help? Thanks.

Be sure that you increased the limits for “Running On-Demand All G instances” and not for “All G Spot Instance Requests”. Link bellow.

Also, have a second look that you have picked the right region for your server.

I managed to solve my problems up until “source ~/.bashrc” (Step 6; AWS EC2).

When I input “conda install -yq mamba”, I receive this message:

Collecting package metadata (current_repodata.json): …working… done
Solving environment: …working… failed with initial frozen solve. Retrying with flexible solve.
Solving environment: …working… failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): …working… done
Solving environment: …working… failed with initial frozen solve. Retrying with flexible solve.
Solving environment: …working…
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.

UnsatisfiableError: The following specifications were found
to be incompatible with the existing python installation in your environment:


  • mamba → python[version=‘3.6.|>=2.7,<2.8.0a0|3.8.|3.7.*’]

Your python: python=3.9

If python is on the left-most side of the chain, that’s the version you’ve asked for.
When python appears to the right, that indicates that the thing on the left is somehow
not available for the python version you are constrained to. Note that conda will not
change your python version to a different minor version unless you explicitly specify

The following specifications were found to be incompatible with your system:

  • feature:/linux-64::__glibc==2.31=0
  • feature:|@/linux-64::__glibc==2.31=0
  • mamba → libgcc-ng[version=’>=9.3.0’] → __glibc[version=’>=2.17’]

Your installed version is: 2.31

Note that strict channel priority may have removed packages required for satisfiability.
Selecting previously unselected package python3-xkit.
(Reading database … 60149 files and directories currently installed.)
Unpacking python3-xkit (0.5.0ubuntu4) …]
Selecting previously unselected package ubuntu-drivers-common…]
Preparing to unpack …/ubuntu-drivers-common_1%3a0.9.0~ …
Unpacking ubuntu-drivers-common (1:0.9.0~ …]
Setting up python3-xkit (0.5.0ubuntu4) …###################…]
Setting up ubuntu-drivers-common (1:0.9.0~ …###########################…]
Created symlink /etc/systemd/system/display-manager.service.wants/gpu-manager.service → /lib/systemd/system/gpu-manager.service.buntu@ip-172-31-30-65:~/fastsetup$ sudo apt-fast install -y nvidia-driver-460-server
Created symlink /etc/systemd/system/oem-config.service.wants/gpu-manager.service → /lib/systemd/system/gpu-manager.service.

Can someone help me out? Thanks!

I am falling over at exactly the same point. Managed to install Mamba using: conda install -c conda-forge mamba, which I do NOT recommend, as although I could get the notebooks to open, I could not see the fastai libraries, so some dependencies got screwed.

Can anyone put us out of our misery?

Any update on this? Running into the same error

If you are running Windows anyway, why do WSL?

Install Anaconda, git Pytorch and fastai and create the environment. Anaconda has Jupyter Notebook support built in. You could be doing your homework in an hour.

Sorry, I know this is no help if you must absolutely run in linux. My sympathy, if so.

I am at “Import key pair” in

How do I find:

My public key; or

The contents of my public key, to be inserted into the “Public key contents” text box?

In case it’s helpful, here are directions for getting setup with Ubuntu, Anaconda, fastai, and python in < 45 minutes (I timed it)

Also running into this issue…Installing mamba through ‘conda install -yq mamba’ brings the error:
<< failed with initial frozen solve. Retrying with flexible solve>>. Has anyone managed to solve it? Thanks