Installation [Windows]

(Alexandre Cadrin-Chênevert) #43

@DimaN Anaconda is creating a local virtual environment to embed the python libraries on your windows machine. Cygwin has no information about that environment. Cygwin is simply a linux command prompt emulator for windows; especially useful in the course to connect to an AWS cloud server.

You need to activate the virtual environment in anaconda prompt to use Jeremy’s jupyter notebooks and to execute all the deep learning libraries installed on your windows local machine.

(Pieter ten Have) #44

Hi all,
I’ve just discovered the FAST.AI-course, and the learning method sounds great!
Problem is now that I can’t install awscli from cygwin.
If I type "pip install awscli’, cygwin doensn’t recognize the command “pip”.
(I have a windows-64-bit i5 laptop with anaconda python 2.7, and 2 years of SAS, R and python experience).
I tried commands pip2 and pip3 but they failed too.
On stackoverflow I read I should try to install curl and python to cygwin,
but that failed too. I see lots of cygwin-packages with the word “curl” and “python”,
but which should I select? All? Some?. And how do you actually select a cygwin package because you can’t tick boxes.
Your suggestions are welcome to get awscli running!


(Bijendra Singh) #45

Today was a long day, I had multiple issues in installing cygwin, python, AWS and mix-up for packages between cygwin vs Anaconda.
But, good part is it all worked out eventually. Thanks to the wonderful forum community support.

I had to uninstall awscli which wasn’t going through.
Figured that my python was in cygwin but, AWS was in Anaconda.
@sindhuv’s suggestion of removing Anaconda helped solve this.
I now have aws configured.

Next issue though is that I’m from “ap-south-1a” [Mumbai] region and will need for this region. If anybody has this script, please share.
I’ve already put a request for p2.xlarge EC2 instance…

(Nick Ireland) #46

Hi Jeremy I think it would be useful to annotate the video pointing windows users to this / or similar link: suspect it would have saved me an hour or two of head scratching

(Deepak) #48

guys, iam not able to use pip. i get followinf error
$ pip install awscli
-bash: pip: command not found
i installed 2.7 python and followed all instructions…any help

(Avik Aggarwal) #49

Were you able to solve this issue @brohammer1957??

(Jeremy Demlow) #50

I have the same issue i can’t get this to work


“sudo apt-get install python-pip” worked for me

(Arijit Deb) #52

I am using a AWS windows instance(m4.xlarge), getting below error
Today, when I typed import cv2, I was given this error message: ImportError: DLL load failed: The specified module could not be found. I am trying to run the RF test dataset.
I tried few recommended steps:

  1. python3.dll is present in Anaconda3 installation path.
  2. pip install opencv-contrib-python

None of the above helped.
Please suggest.