Installation [Windows]

I am going through the installation phases and was watching Jeremy’s video. In the part after you install awscli via the pip command, when I run aws in the cygwin terminal I get the message that no such file is present. In order to actually get the output that Jeremy gets when he runs the command aws I need to switch to the ~/Anaconda/Scripts directory and run the command ./aws
Part of me think there is some intermediate step after pip install awscli and before running aws command instead of having to go through the above steps of switching directories and running the ./aws command.

Edit: Looking online, I found a solution that worked for me:
Basically you need to install a pip version in cygwin


Actually I mis-spoke in that video - when in Cygwin, I see that I’m actually using the cygwin python, not anaconda. So you may find it easiest to just install python through cygwin, then pip install awscli again.

[ Answer edited ], since it wasn’t related to the awscli.

I wouldn’t recommend using VirtualBox or any virtual machine - they don’t provide access to the GPU so your training will be unbearably slow. Installing theano and keras on Windows is at least as easy as it is on Linux or Mac.

Having said that, @vshets question wasn’t about deep learning frameworks, but about using awscli. It should work just fine using Anaconda and powershell, or using cygwin and cygwin’s python. It’s mixing and matching the two (Anaconda and cygwin) which causes difficulties.

1 Like

I am still getting this problem.

I tried reinstalling Cygwin and following the steps mentioned by @vshets in the StackOverflow answer linked but it did not work for me.

However the AWS tools are available in Command Prompt, will that work?

Assuming you are on Windows 10, have you tried running everything using the new bash utility?

It has both current versions of 2.7.x and 3.4.x ready to go and you can forego having to install and use cygwin. There are a few quirks I don’t care for (e.g., copy&paste isn’t intuitive) but overall it feel linux-ish enough for me.


What is the keyboard shortcut for copy+paste in the win bash environment? BTW win bash is so awesome I ditched cygwin for good!

Sorry there is none!


This is going to sound weird … but what you do is highlight what you want to copy and rt-click. To paste, rt-click wherever you want to paste the text in bash.

I don’t like it but that is what we got in Windows right now.

1 Like

Hi @wgpubs, I tried that, but I’m using my work laptop and for some reason IT has disabled this feature, so this isn’t an option too.

Ok, I found the solution for this, I uninstalled Anaconda, followed the steps mentioned in the wiki, and then reinstalled Conda, now i have the AWS tools in Cygwin and Anaconda also working properly


As others have reported, the video explains the installation in the reverse order from what works on Windows. If you install anaconda before installing cygwin, then awscli will install to the wrong python distribution. I was able to fix this by installing in the opposite order.

So now I have aws “working”, but the bash install script for p2 doesn’t work, generating a lot of errors that look like what was reported by Cristina here (even though she running the t2 install script, whereas I’m running the p2):

In the forum, someone said it was likely a problem with aws credentials, but I have confirmed that the credentials are correct. So I’m totally stuck on this front.

On another front, I tried to just get things installed to run the materials locally on my computer. It wasn’t too hard to get anaconda, theranos, and keras installed, but I’m struggling to get CUDA support up and running (I do have an Nvidia graphics card with cudas and have successfully used cuda support for 3d rendering).

When I run Nvidia’s CUDA installer (I’ve tried both 7.5 and 5.5) it tells me I need to install Visual Studio and provides a link to do that. I go to that link and download and install Visual Studio, then re-run the CUDA installer and it still tells me I need to install Visual Studio.

I think the problem is that the CUDA installer requires a specific, older version of Visual Studio, whereas the link takes you to a Microsoft portal that only lets you install the latest version. How do I get an older version of Visual Studio that will actually work with the CUDA installer?

I’m running 64-bit Windows 7.

So, currently I’m stuck on both fronts - installing for working with AWS and installing to work locally. Would appreciate help.

The link I provided seems to link to one post below Cristina’s post, so scroll up to see the errors I’m talking about.

I’m so used to this kindof crap it doesn’t even phase me :smiley:

@puzzler, I am using Windows 10 and all works fine.
I installed Anaconda 2, Keras and CUDA 8.0, Python 2.7 in Windows 10 and could run notebook with no problems, even using gpu. Then, to access AWS remotely, I am using Bash for Windows. where I installed aws that did allow me to install the necessary instances.

1 Like

I am not on Windows 10, so need a working solution using cygwin as shown in the video.

The easiest way to fix the cygwin issue is to install python into cygwin (by re-running cygwin’s setup, and selecting python), then pip installing awscli again in cygwin.

Is it possible to get a bit more explicit instruction on the “re-installing” point ? I get a consistent ‘file not found’ error message when entering ‘aws’ at the Cygwin $ prompt. I have uninstalled Anaconda and Cygwin and then reinstalled Cygwin (first) and then Anaconda (anaconda 3, Python 3.6 in a Windows 8 (64) environment). This does not resolve the problem. Does “re-running Cygwin’s setup” mean uninstalling and then reinstalling Cygwin (which implies having to do the same with Anaconda) or is there a more straightforward, easier and efficient way to do this ? Also, how specifically to “select” Python (two options for this in the Cygwin setup, from what I can see).

Hey guys, just want to throw this out there. For people who, like me, are installing everything from scratch, in my case, in my personal computer, the cudnn v6.0 version won’t work with theano, and you should downgrade to v5.0. The error was thrown when compiling, because of a change in the cudnn api: error: identifier cudnnSetFilterNdDescriptor_v4 is undefined

Just feel like this could help someone who is out there looking for help!

Actually I’d revise my earlier advice and instead say: use Ubuntu Bash for Windows. It’s more separate from the main windows binaries, so you don’t get these same problems.